Camino CPU usage jumps to 100%

RESOLVED DUPLICATE of bug 310222

Status

Camino Graveyard
General
--
major
RESOLVED DUPLICATE of bug 310222
11 years ago
11 years ago

People

(Reporter: Matthew Hutton, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Spoofing to Firefox 1.5 Mac with CamiTools 4.6, running Camino Version 2006110322 (1.1a1+), on an Intel Core Duo Macbook 2Ghz with 2GB RAM

CPU Usage seems to randomly jump to 100%,, has happened with several different recent nightlies, the web addresses give the currently open pages.

Reproducible: Didn't try

Steps to Reproduce:
Just browsing the web with on the sites indicated
Actual Results:  
CPU usage went to 100%

Expected Results:  
CPU usuage should have stayed around 10%
(Reporter)

Comment 1

11 years ago
Created attachment 245003 [details]
Open Files and Ports of Camino from Activity Monitor

The currrent Open Files and Ports from Activity Monitor
(Reporter)

Comment 2

11 years ago
Created attachment 245004 [details]
Sample of Camino taken from Activity Monitor

Sample of Camino Taken from Activity Monitor

Comment 3

11 years ago
The sample sure points to this being a dupe of bug 310222.

If you temporarily remove the Flash plugin from /Library/Internet Plug-ins/, does performance improve?

cl
(Reporter)

Comment 4

11 years ago
It doesn't seem to be reproducable since the day I sent in the report, though it doesn't seem to be flash related, CPU only goes to about 16% with http://www.museum.tv/home.php (site causing problems for the other user) and http://www.flash-game.net/game/633/moon-lander.html (a flash game), and Camino doesn't need force-quitting.

The museum.tv site took a second to close the window but the flash game closed instantly.

I currently have Flash version 9.0.20 installed.

Maybe because I have a dual core Mac, but Camino was still useable (though a bit slow at times) I even sent the original bug report with Camino while it was running with 100% CPU.
(Reporter)

Comment 5

11 years ago
For comparison with just this page idling after restarting Camino it uses 3% CPU, however with just this tab before restarting it was using about 11.5% CPU.
(Reporter)

Comment 6

11 years ago
Apologies for spamming you guys with lots of bug report emails :(, but I was thinking that it could be flash related if it was caused by a badly designed web ad (aren't they all :rollseyes: ), especially as none of the url's normally contain Flash content.

As I have no idea when they are going to load, wouldn't it be best to slowly close the tabs until they are all closed and see what happens to CPU performance?
(Reporter)

Comment 7

11 years ago
Seems to be caused by Orange Broadband (Flash) ad's as soon as those tab's were shut the problem went away, and it reduced the less of them were open

Comment 8

11 years ago
I'm gonna mark this as a dupe of 310222, then.

*** This bug has been marked as a duplicate of 310222 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.