Autocompleate changes textbox unexpectedly

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: garyvdm, Assigned: garyvdm)

Tracking

(4 keywords)

unspecified
platform-parity, polish, ue, uiwanted
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
This is bug where the behavior is not what the user (me) expects.

Steps to reproduce:
1. Goto  http://www.google.com/
2. Type "abc efg" in to the textbox. Click search. ("abc efg" will now be in the autocomplete list.)
3. Dbl-click on "abc" in the text box. Intention of the user is to select abc, but autocomplete list also shows.
4. Move mouse over autocomplete list. This is an unintentional move by the user, but something that happens naturally as one move the mouse away from the textbox before typing. The result is the item in the autocomplete is selected.
5. Type "hij" which overrids "abc" as it was selected. The text in the textbox now reads "hij efg".
6. Press enter.

Actual result: The text box is unexpectedly changed back to "abc efg" and the form is submitted.

Expected result: The text box should remain as "hij efg" and the form is submitted.

Possible solutions: 
Solution 1: Items in the autocomplete list are not selected on mouse over, only on click.

Solution 2: Items in the autocomplete list are selected on mouse over, but if the mouse leaves the autocomplete list, none are selected.

Solution 3: Items in the autocomplete list are selected on mouse over. If the item was selected using the mouse (not the keyboard), pressing enter does not change the textbox.
Hitting down arrow or first clicking beside the field before pressing enter, or single click before double clicking in the field, or just using the back key for text changes should help ;).
I think this is basically a dupe of bug 79069.

Comment 2

12 years ago
Or is bug 79069 specific to Seamonkey's location bar?
(Assignee)

Comment 3

12 years ago
Created attachment 245641 [details] [diff] [review]
Patch rev0

Unselect item on mouseout
Assignee: nobody → garyvdm
Status: UNCONFIRMED → ASSIGNED
(Assignee)

Updated

12 years ago
Attachment #245641 - Flags: first-review?(mconnor)
(Assignee)

Updated

12 years ago
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Updated

12 years ago
Flags: blocking1.9?

Updated

12 years ago
Attachment #245641 - Flags: first-review?(mconnor) → review?(mconnor)
A quick exploration shows that:

On Windows: drop-down selection retains highlight onMouseOut, but using keyboard based select will replace the contents in the textbox, so hitting enter always executes textbox contents. Thus this issue is solved in a way that's closer to bug 79069.

On OSX: drop-down selection is deselected onMouseOut if it was selected onMouseIn; if it was selected by keyboard navigation, then it will retain selection even onMouseOut (until it's reselected by the mouse, that is)

On Linux: I didn't test, but I bet it's like Windows.

This isn't a blocker, but it's a platform-parity polish issue that we should clean up. I'd also support the OSX behaviour on all platforms, since it feels like the nicest thing to do.
Flags: blocking1.9? → blocking1.9-
Keywords: polish, pp, ue, uiwanted
(Assignee)

Updated

11 years ago
Attachment #245641 - Flags: review?(mconnor)
(Assignee)

Comment 5

11 years ago
I just downloaded a nightly - and I see that my problem was fixed by bug 79069.
--> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.