import from outlook fails with "error writing temporary file", freezes thunderbird

RESOLVED DUPLICATE of bug 262735

Status

Thunderbird
Migration
RESOLVED DUPLICATE of bug 262735
12 years ago
12 years ago

People

(Reporter: Jurgis Lukss, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

When importing Outlook mailbox, import fails with error dialog box, which states - "Unable to save your message as Draft. Error writing temporary file".

Cause seems obvious - there is not enaugh free space on my hard disk. But clearing up additional 300 Mb of disk space, does not remove this message. Clicking "Ok", just  brings it up again. I found some files (nsmail.eml,mapiattach.tmp,SOF153.tmp,TBR14A.tmp...) in my Local Settings > Temp folder, which seem to be a cause of problem. File nsmail.eml is never deleted and I cannot delete it (lock). And clicking on "Ok" button just writes some additional tmp files, which are later cleared up, but nsmail.eml file is never touched. File nsmail.eml usually contains a huge e-mail with big attachments (i be).

Only way to stop this is by killing Thunderbird process. What won't be obvious to casual users, and as Mozilla aims at casual users, I believe this problem must be addressed.

I repeted this process several times, every time clearing up additional hard disk space, and it always stops on a different email message (checked that from nsmail.eml file) so it obviosly is a free space problem and not a corrupted message, that causes this Error message loop.

Reproducible: Always

Steps to Reproduce:
1. Have a huge Outlook mailbox to import
2. Fill up disk space or set quota on Temp folder
3. Select Tools > Import > Outlook
4. Wait for error message

Actual Results:  
"Unable to save your message as Draft. Error writing temporary file"

Expected Results:  
"Not enough free space to complete import. Error writing temporary file. Please free up more space on hard drive C: and press Retry" [Retry], [Ignore], [Abort]

There is a bug Nr.325095 which seems related, but there are not enough conclusions on the causes of the error.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 262735 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.