DIR-LI value attribute: the value attribute is not recognized

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
20 years ago
19 years ago

People

(Reporter: rubydoo123, Assigned: buster)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
build: 3/7/99 -  3/10/99
platform: win95, win98, winNT, mac, linux
expected results: when value attribute set to a numeric value, the list item
marker should be rendered as a numeric value
what I got: the list item marker rendered as bullets

steps to reproduce:
here is the code
<dir>
<li VALUE=10>directory list using the LI value attribute, list item marker value
set to 10</li>
<li VALUE=20>list item marker value set to 20</li>
<li VALUE=30>list item marker value set to 30</li>
</dir>

Updated

20 years ago
Assignee: troy → kipp
(Reporter)

Comment 1

20 years ago
this is also broken when using the MENU element

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID

Comment 2

20 years ago
DIR and MENU are unordered lists; therefore there default "type" is disc which
means the "value" parameter will be ignored. Try it in navigator to see it work
the same as in nglayout.
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 3

20 years ago
a valid attribute for the LI element is value, LI is a child of MENU and DIR,
regardless as to how previous version display this. Setting the value attribute
should owrk the same across the parent elements. Reopening bug
(Reporter)

Updated

20 years ago
Resolution: INVALID → ---

Updated

20 years ago
Status: REOPENED → ASSIGNED

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → INVALID

Comment 4

20 years ago
The bug report is still wrong Wrong WRONG.

The only time the value attribute applies is when the type of the list-item is a
numeric or counting value or if the container is an ordered list or has its type
forced to be a numeric or counting value. Since *NEITHER* is true in this case
(MENU and DIR are unordered), its an invalid bug report. Meerly setting VALUE is
not enough. Set TYPE as well to see it work (e.g. bug #3597 shows examples of
counting elements inside a DIR - TYPE is set for each LI allowing them to
count).
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

20 years ago
well I still disagree with ya but, since you do the development - you win. Since
DIR & MENU do not have a type attribute associated with them, they can't have
the type value changed, so it would be just a bit hard to that.  closing the bug
You need to log in before you can comment on or make changes to this bug.