Cloning a test case with copy document also clones the entire document history

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: keith.mcfall, Assigned: gregaryh)

Tracking

x86
Windows XP

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Cloning a test case and including the option 'copy document' causes the entire document history of the cloned from test case to be passed on to the clone.

Reproducible: Always

Steps to Reproduce:
Steps to Recreate:
1. Create a test case with a few version on it. (i.e 5)
2. Clone the test case as a copy. Make sure copy document is checked.
Actual Results:  
The new test case has the same document history as the original.
When cloning a test case, the entire history of the test case comes with it.

Expected Results:  
I expected that the copy document feature would copy the most recent document version only.

If there is some reason why it makes sense to also clone the history of a test case when creating a new copy I would expect this as an option, otherwise, I would expect the copy to take only the most recent document since the history actually has nothing to do with the test case itself.

Updated

12 years ago
Version: unspecified → 1.1
(Assignee)

Comment 1

12 years ago
    Checking in Bugzilla/Testopia/TestCase.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/TestCase.pm,v  <--  TestCase.pm
    new revision: 1.18; previous revision: 1.17
    done
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.