Profile corrupts almost daily, often between dual boots between Linux and Windows XP, but occasionally at other times without warning

RESOLVED DUPLICATE of bug 58647

Status

()

Toolkit
Startup and Profile System
--
critical
RESOLVED DUPLICATE of bug 58647
11 years ago
9 years ago

People

(Reporter: pacshady, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I have a dual-boot system with Kubuntu (Dapper) Linux, and Windows XP, with a FAT32 drive in between which I share files on, including my Mozilla Firefox and Thunderbird profiles on to share preferences between operating systems. A few days ago, I was using Firefox on my Linux boot, I closed it, and reopened it later and all my extensions options, Firefox options and bookmarks weren't functioning. I booted into Windows, and was told the bookmarks.html was corrupted. Ran Chkdsk, lost all my settings and bookmarks, had to restart a new profile. Next day, corruption happened again, and the next day, and finally today. The problem seems to occur most often when changing operating systems, but otherwise can occur randomly, even in the middle of using Firefox. The error also occurred on my Thunderbird profile the first day, but so far the problem hasn't occurred again. But the problem with Firefox is becoming repetitive and annoying, and I've now had to back up my profile every day (and sometimes several times a day) just to make sure I can keep using it. If I could find out where Chkdsk stores log files I'd be able to attach it here to show which files are being affected. I've run various tests on the hard drive to determine if the hard drive is failing, but so far nothing has come up; the hard drive appears to be in perfect health. The shared profile has worked fine for several months up until a few days ago, and since then the problem keeps occurring.

Reproducible: Sometimes

Steps to Reproduce:
Since the problem seems to happen most when switching operating systems, the easiest way I can see to reproduce the problem would be:
1. Install a dual-boot system between Windows XP and Kubuntu (Dapper)
2. Install Firefox 2.0 on both systems (official build for Kubuntu, not Debian repository build)
3. Set up a FAT32 drive between systems and place Firefox profile on there, directing both browsers to look at that folder
4. Use Firefox, restart to other OS, try using Firefox again
Actual Results:  
Several vital files in the Profile folder become corrupted. Bookmarks, Firefox prefs and extension prefs unavailable.

Expected Results:  
Should work normally

Since this error only occurred in the last few days however, I don't think it's going to be easily reproduced. So instead, I am willing to send any error files I can regarding my system, if someone tells me what files they need.
(Reporter)

Comment 1

11 years ago
I have some additional info (it happened again today, who would've guessed?)

IN LUNUX:

This error appears when Firefox starts after the profile has corrupted, before the Firefox window has loaded:
"Could not initialize the browser's security component. The most likely cause is problems with files in your browser's profile directory. Please check that this directory has no read/write restrictions and your hard disk is not full or close to full. It is recommended that you exit the browser and fix the problem. If you continue to use this browser session, you might see incorrect browser behaviour when accessing security features."

Then after the window has loaded:
"Session Manager cannot load its database from corrupted session.rdf.
The file session.rdf will be deleted, a copy can be found in session.old in your profile."

Firefox and extensions revert to default settings, and I lost most (but not all) of my bookmarks.


IN WINDOWS:

TabMix Plus extension asks which session restore to use, its own or Firefox's (demonstrating a loss of settings). Whether Yes or No is selected the setting isn't saved.

All my bookmarks are lost. All settings revert to default, including the Firefox update website and the default Firefox/Google search engine (as separate tabs).

Upon shutting down Firefox, a Balloon alert comes up in the System Tray:
"The file or directory \Mozilla\Firefox\Pac Shady\bookmarks.html is corrupt and unreadable. Please run the Chkdsk utility."

Firefox sometimes fails to unload from memory when it's closed at this point, process must be killed in Task manager.

Chkdsk results (from this particular corruption, I distinctly remember the first time it happened more than this was "corrected", ie. deleted by Chkdsk):
\Mozilla\Firefox\Pac Shady\cookies.txt  first allocation unit is not valid. The entry will be truncated.
\Mozilla\Firefox\Pac Shady\prefs.js  first allocation unit is not valid. The entry will be truncated.
\Mozilla\Firefox\Pac Shady\session.rdf  first allocation unit is not valid. The entry will be truncated.
\Mozilla\Firefox\Pac Shady\localstore.rdf  first allocation unit is not valid. The entry will be truncated.
\Mozilla\Firefox\Pac Shady\bookmarks.html  first allocation unit is not valid. The entry will be truncated.

Comment 2

11 years ago
Duplicate of Core bug 58647?
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 58647
You need to log in before you can comment on or make changes to this bug.