bugzilla2.22 can't find any bugs with status=closed.

RESOLVED DUPLICATE of bug 349026

Status

()

RESOLVED DUPLICATE of bug 349026
12 years ago
12 years ago

People

(Reporter: slava, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 

when I executing search with status='closed', product='main site', words='' I receive a messaqe 'Zarro Boogs found.' ALWAYS.
you may be sure our database HAS many closed bugs with status 'CLOSED  FIXED'
however, when I use Advanced Search for searching closed bugs, it works fine.


Reproducible: Always

Steps to Reproduce:
1. open 'Find a Specific Bug' page
2. select closed status at selectbox
3. execute search

Actual Results:  
Zarro Boogs found

Expected Results:  
list with closed bugs

write slava <<at>> doostang <<dot>> com and I'll help you receive any possible information about it
The URL used is correct.  "__closed__" is a distinct entity from "closed", and means something different...  the one with the underscores is special-cased to mean any non-open status.

That said, using __closed__ *should* find the closed bugs in your installation, as "closed" is indeed a non-open status.

The code doing this is in Bugzilla/Search.pm:

        elsif ($bug_statuses[0] eq "__closed__") {
            $params->param('bug_status', grep(!is_open_state($_),
                                              @legal_statuses));
        }

where @legal_statuses is:

        my @legal_statuses = @{get_legal_field_values('bug_status')};

and is_open_state compares against BUG_STATE_OPEN, which is defined in Bugzilla/Constants.pm as:

# States that are considered to be "open" for bugs.
use constant BUG_STATE_OPEN => ('NEW', 'REOPENED', 'ASSIGNED',
                                'UNCONFIRMED');

So there's three ways to get the behavior you're seeing:
1) you have CLOSED included in your BUG_STATE_OPEN constant (local hack?)
2) the CLOSED bugs are all in products that require group membership for access, and you're not logged in as a user that's a member of that group when you run the query
3) Something in Bugzilla is broken (not likely since it works on landfill, but you never know -- need more proof than we've got so far if that's the case though)

Comment 4

12 years ago
We can't reproduce, so this is WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

12 years ago

*** This bug has been marked as a duplicate of 349026 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.