Closed Bug 360253 Opened 13 years ago Closed 13 years ago

Text cursor obscured by coincident div regardless of z-index

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 167801

People

(Reporter: cfmdobbie, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

It seems that a div will obscure a text cursor if it is included in the markup after the textfield, regardless of the z-index of each.

My test-case includes two divs, absolutely-positioned such that they overlap, with the first div containing a textfield and positioned to z=101 and the second positioned to z=100.  In the area where they overlap, the first div is displayed in front of the second.  However, in that area, the text cursor is not displayed.

Reproducible: Always

Steps to Reproduce:
1. Open test-case.
2. Edit the text in the textfield, observing when cursor is visible.

Actual Results:  
Text cursor is not displayed when in same region as the light-gray div, even though the z-index of that div puts it behind the dark-gray div, and thus behind the textfield.  Text cursor displays as normal when not in the same region as the light-gray div.

Expected Results:  
Where the text-field is visible, the text cursor should be visible.

Issue seems similar at first to bug 350678, but I do not believe this situation is explainable by the same stacking context rules that that one was.
Testcase added.  Passes validation as per doctype.
This is fixed on trunk.

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
This bug is not fixed! Much divs "position:absolute" and some textareas... and the cursor is not visible but active!
You need to log in before you can comment on or make changes to this bug.