mp3 files no longer download with update. download manager does not start

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Daniel Malcolm, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

wit hthe new update, when i click the download button for an mp3 file on myspace, nothing happens. other sites work fine

Reproducible: Always

Steps to Reproduce:
1.click download on a song with this option
2.
3.

Actual Results:  
nothing

Expected Results:  
download manager to download the file

Comment 1

12 years ago
I am having the same problem. Recently upgraded to Firefox 2.0, and I get the normal prompt for where I want to save a download to, but then nothing happens afterwards. 

Comment 2

12 years ago
i ran into this same problem on an almost-fresh install of firefox 2 on linux. don't know what triggered it.

deleting downloads.rdf, localstore.rdf, mimeTypes.rdf made no difference.

the problem was fixed after deleting all the files except bookmarks.html and history.dat from the profile.

would be really nice if someone found a way to reproduce this bug.

Comment 3

12 years ago
it happened again. now i notice that if i right-click on the mp3 link and choose 'save link as' it does work.

as before, if i left-click on the link and choose a place to save it and click save, the file is not downloaded but a 0-length file with the proper name in the right place is created.

also, i noticed that on some sites, like http://pa.gigavox.com/shows/detail1568.html left-clicking on the download link gives you one filename and right-clicking on the same link doing a save as gives you a different filename.

is this enough to change the bug status to confirmed? i'm not going to delete this profile so i can try more things to find out what's wrong.

Comment 4

12 years ago
hm, strange. it seems that i only have this problem when trying to save to /mnt/usb, which is mounted by me:

/dev/sda1        /mnt/usb         vfat        defaults,noauto,user,umask=0 0   0

downloading to anywhere else works fine, even to an nfs-mounted volume.

i think i'm gonna give up trying to figure this one out :)
Can you still reproduce the bug with the old version? In other words, was it just a fluke that this started happening with the new build?

Comment 6

12 years ago
not sure what you're asking. it's firefox 2.0. i don't do mozilla development work on this machine.

i have no idea what triggers this. it just started happening all of a sudden, both times.
Comment 0 mentions that the problem happens only after an update to 1.5.0.8, and your comment alludes to an update to Firefox 2. Then you later mention that it only happens with a certain directory. If you can consistently reproduce the problem, then a good first step is to see whether it is actually a regression, which is why I asked whether you can reproduce it in the 'older' build. It's not clear from your comments whether the issue you're seeing is the same as the one that was originally reported (comment 0). It's also not clear what the exact steps to reproduce are, or what the expected/actual results are, which makes it hard to understand the bug.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch

Comment 9

11 years ago
Works for me now. Firefox 2.0.0.4. I guess noone knows when this was fixed? Maybe it should be left open for a while? At least for a couple of weeks, so I have more opportunity to reproduce it.
Sure, we can leave this open for a while longer.

Comment 11

11 years ago
well, it looks like it works now. i guess it's safe to close
--> WFM. Thanks Andrew!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.