Query Boolean for comment doesn't work well

RESOLVED DUPLICATE of bug 45862

Status

()

RESOLVED DUPLICATE of bug 45862
12 years ago
12 years ago

People

(Reporter: bigstijn, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

At this moment, I have the case that I can't exclude a bug from a search, using the boolean charts on comment, although the bug search criteria aren't met, and vice versa.

Case:
https://bugzilla.mozilla.org/show_bug.cgi?id=357847#c3 contains the string / word "Windows," (remove quotes) .

The bug is still appearing in the searches using boolean charts:

1) Comment contains none of the words --> Windows
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&product=Bugzilla&component=Installation+%26+Upgrading&version=2.23&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_status=NEW&bug_severity=normal&op_sys=Windows+XP&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=longdesc&type0-0-0=nowords&value0-0-0=Windows

2) Comment contains none of the words --> Windows,
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&product=Bugzilla&component=Installation+%26+Upgrading&version=2.23&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_status=NEW&bug_severity=normal&op_sys=Windows+XP&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=longdesc&type0-0-0=nowords&value0-0-0=Windows%2C

3) Comment contains none of the strings --> Windows,
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&product=Bugzilla&component=Installation+%26+Upgrading&version=2.23&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_status=NEW&bug_severity=normal&op_sys=Windows+XP&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=longdesc&type0-0-0=substring&value0-0-0=Windows%2C

And so on, for
contains none of the strings Windows
not contains the string Windows

..

Reproducible: Always

Steps to Reproduce:
1.see above



Expected Results:  
Bug 357847 isn't in the result list.

Comment 1

12 years ago
joel, this bug looks similar to bug 323905. Same issue? Already fixed on tip?
Version: unspecified → 2.20

Comment 2

12 years ago
bug 45862
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 45862
You need to log in before you can comment on or make changes to this bug.