Firefox URL shortcut appears as IE icon when using Large Icons (48 x 48)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
6 months ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

If you have Large Icons specified for Windows and save a Web page or URL to the desktop it gets an Internet Explorer icon, even if Firefox is the default browser.

Reproducible: Always

Steps to Reproduce:
1.  Set Windows to use Large Icons using Display Properties | Appearance tab | Effects | Select Large icons. 
2.  Set Firefox 2.0 as the default browser.
3.  Set Internet Explorer 7 as not being the default browser.
4.  In Set Program Access and Defaults make sure Firefox is set as the default browser.
5.  When browsing with Firefox, drag a URL from the address window onto the desktop.
6.  When browsing with Firefox, save a file onto the desktop.
7.  Find firefox.exe and make a shortcut to it on the desktop.
Actual Results:  
#5 and #6 give icons with the Internet Explorer 7 logo.
#7 gives an icon with the Firefox logo.

Expected Results:  
#5, #6 and #7 should all give an icon with the Firefox logo.

In http://groups.google.com/group/mozilla.support.firefox/browse_frm/thread/141c8ecef13f2be3/4fda36f699222f35?lnk=st&q=%22Firefox+icon+seen+in+folders+is+OK%22&rnum=1#4fda36f699222f35
Cal Tinson says this problem did not occur before installing Internet Explorer 7.  I can't add data of my own here because I set Firefox to be the default browser only after installing Internet Explorer 7.

Comment 1

12 years ago
This works for me having large icons enabled and IE 7 and Firefox 2 installed.

Can you please test the following and see if it fixes the issue?
http://iconfactory.com/home/show/1530
(Reporter)

Comment 2

12 years ago
As stated in the original report, changing between large and small icons was already tried and the Internet Explorer image comes back when returning to 48 pixel icons.  This was tried with both the method described in the original report and the method described in http://iconfactory.com/home/show/1530.  

In addition, rebooting didn't help, and using TweakUI's Repair | Rebuild icons didn't work either.

Two others in the mozilla.support.firefox group cited in the original report are also seeing the same problem.  It is not clear why it appears on some systems and not on others.
(Reporter)

Comment 3

12 years ago
Just for clarification, can I presume that "This works for me" means that using scenarios #2 and #3 with 48 pixel icons you see the form of icon with a small Firefox globe on a white rectangle?  Scenario #1 with a large Firefox globe and no white rectangle works for everyone as far as I can tell.

Comment 4

12 years ago
I have noticed a similar bug : the icon shown both with big and small icons and anywhere else (including in folders or start menu) is the Firefox logo, not the page image with a small Firefox logo like it is for the html files.
The bug I describe comes from the registry key
[HKEY_CLASSES_ROOT\FirefoxURL\DefaultIcon]
being 
@="C:\\PROGRA~1\\MOZILL~1\\FIREFOX.EXE,0"
instead of
@="C:\\PROGRA~1\\MOZILL~1\\FIREFOX.EXE,1"

Mickey> Have you also tried to set the screen bit depth to 16 bits and then back to 32 bits ?
If this doesn't work either, it could be a problem specific to IE7.

Comment 5

12 years ago
The similar bug you found is bug 372236.

Comment 6

12 years ago
Thanks for the info.
(Reporter)

Comment 7

12 years ago
The problem disappeared shortly after I reported it in November.  I don't know what accounted for the disappearance of the problem, and it has not come back.  I have since done a clean install of Vista and not seen the problem there either.

I don't know if this is relevant, but I had TweakUI installed on the XP computer.

Comment 8

12 years ago
Had the same problem than Mickey Segal with WindowsXP Home, IE7 and Firefox2.0.0.3
(had set "shell icon size" to 48).
Firefox was default browser and in all cases a shortcut on the desktop had the de-
-fault icon of Internet Explorer.
At 32 I could with a right clic (properties) modify the icon, not at 48 or above.
Because at 32 a right clic gave two options (general and "web document") and above
32 only one (general), hence not the possibility to customize my shortcut.
Got rid of IE7 and no problem with IE6...
I say the second option was not only inaccessible but not there at all.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Possibly fixed on trunk by bug 340976
Pretty sure this is no longer an issue on modern Firefoxen/Windows(es).
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.