If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Computer Does Not Shut Down When Firefox Tabs Are Open.

RESOLVED DUPLICATE of bug 309849

Status

()

Firefox
Shell Integration
--
major
RESOLVED DUPLICATE of bug 309849
11 years ago
11 years ago

People

(Reporter: Bud Willner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

When the computer is scheduled to shut down at a regular scheduled time and Firefox is open with tabs open,computer shutdown times out.

Computer shutdown process is waiting for a response from Firefox to close tabs so Firefox can be closed/shutdown before shutting down the computer.  This process should be as other applications work.  Firefox should do the same.

Bud Willner

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Open Tabs
3.Wait for scheduled shutdown.

Actual Results:  
Firefox opens dialog box requesting if tabs should be closed.
Computer waits for response to the Firefox Dialog request.
If no response is made, computer shutdown times out.

Expected Results:  
Firefox to close all tabs and shutdown so computer can shut down at scheduled time.

Shut down.

Comment 1

11 years ago
DUPLICATE of bug 227348?

Comment 2

11 years ago
Hmm, rereading the report this is ofcourse OS X, and bug 227348 is Windows. While the problem is the same, the code fix most likely is not.
(Reporter)

Comment 3

11 years ago
Be assured the problem is not just scheduled shutdown but also when asking the computer to restart or shutdown (for whatever reason).

Bud Willner

Comment 4

11 years ago

*** This bug has been marked as a duplicate of 309849 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.