crash [@ nsXULDocument::ResumeWalk] when viewing source on XUL doc

VERIFIED DUPLICATE of bug 359959

Status

()

Core
XUL
--
critical
VERIFIED DUPLICATE of bug 359959
11 years ago
7 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

218 bytes, application/vnd.mozilla.xul+xml
Details
 
(Reporter)

Comment 1

11 years ago
Created attachment 245472 [details]
testcase
(Reporter)

Comment 2

11 years ago
>	gklayout.dll!nsXULDocument::ResumeWalk()  Line 2992 + 0x14 bytes	C++
 	gklayout.dll!nsXULDocument::OnPrototypeLoadDone(int aResumeWalk=1)  Line 559 + 0xe bytes	C++
 	gklayout.dll!nsXULDocument::EndLoad()  Line 543	C++
 	gklayout.dll!XULContentSinkImpl::DidBuildModel()  Line 433	C++
 	gkparser.dll!nsExpatDriver::DidBuildModel(unsigned int anErrorCode=0, int aNotifySink=1, nsIParser * aParser=0x040fd210, nsIContentSink * aSink=0x04240070)  Line 1267 + 0xe bytes	C++
 	gkparser.dll!nsParser::DidBuildModel(unsigned int anErrorCode=0)  Line 948 + 0x35 bytes	C++
 	gkparser.dll!nsParser::ResumeParse(int allowIteration=1, int aIsFinalChunk=1, int aCanInterrupt=1)  Line 1682	C++
 	gkparser.dll!nsParser::OnStopRequest(nsIRequest * request=0x04ca77e0, nsISupports * aContext=0x00000000, unsigned int status=0)  Line 2306 + 0x17 bytes	C++
 	jar50.dll!nsJARChannel::OnStopRequest(nsIRequest * req=0x04ca7b38, nsISupports * ctx=0x00000000, unsigned int status=0)  Line 752	C++
 	necko.dll!nsInputStreamPump::OnStateStop()  Line 572	C++
 	necko.dll!nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream * stream=0x04ca7c38)  Line 396 + 0xb bytes	C++
 	xpcom_core.dll!nsInputStreamReadyEvent::Run()  Line 112	C++
 	xpcom_core.dll!nsThread::ProcessNextEvent(int mayWait=1, int * result=0x0012fbc4)  Line 483	C++
 	xpcom_core.dll!NS_ProcessNextEvent_P(nsIThread * thread=0x00b5c6d8, int mayWait=1)  Line 225 + 0x16 bytes	C++
 	gkwidget.dll!nsBaseAppShell::Run()  Line 153 + 0xc bytes	C++
 	tkitcmps.dll!nsAppStartup::Run()  Line 171 + 0x1c bytes	C++
 	xul.dll!XRE_main(int argc=4, char * * argv=0x00b58f40, const nsXREAppData * aAppData=0x004036b0)  Line 2513 + 0x25 bytes	C++
 	firefox.exe!main(int argc=4, char * * argv=0x00b58f40)  Line 61 + 0x13 bytes	C++
 	firefox.exe!__tmainCRTStartup()  Line 586 + 0x19 bytes	C
 	firefox.exe!mainCRTStartup()  Line 403	C
 	kernel32.dll!7c816fd7() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]	
(Reporter)

Comment 3

11 years ago
This works fine on the 1.8.1 branch.
Keywords: regression

Comment 4

11 years ago
This is fixed now.

*** This bug has been marked as a duplicate of 359959 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: crash
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

11 years ago
Ah. Thanks.

Comment 6

11 years ago
v.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsXULDocument::ResumeWalk]
You need to log in before you can comment on or make changes to this bug.