X server hang on drag-and-drop from modal "Save Link As" dialog.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: phrh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 11/30)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When saving from the right click menu of a link, a modal Gnome "Save File As" dialog pops up, leaving the background Firefox window behind.

I can see that the background Firefox window does not respond to the mouse (it shows the hand cursor everywhere).

If I accidentally drag a file from the Save As dialog into Firefox, I get permanently stuck with the right angle DND cursor (and the little symbol disappears as it moves over the window.

Reproducible: Always

Steps to Reproduce:
1. Right click on any link, and select "Save Link As..."
2. Firefox window becomes unresponsive because there is a modal dialog.
3. Select a file in the right pane of the file dialog.
4. Drag the file over the Firefox browser window until the symbol on the right angle cursor changes.

Actual Results:  
This causes the entire X server to hang on the mouse grab.  CLicking or releasing anywhere does not help.
Neither keyboard nor mouse respond any longer, and the only way to release the grab as far as I have tried is to killall firefox-bin from a console.

Expected Results:  
Firefox should more gracefully handle dragging and dropping over a frozen window, or should prevent drag-and-drop from the "save as" dialog (I don't even see how it's useful in that case.)

I'm using X.Org 7.1 on Debian Etch/testing.
I'm using the official (not Debian) Firefox build.

Comment 1

12 years ago
Might be a dupe of bug 100180 (pressing ESC doesn't help). Sure is, if Firefox is supposed to show a dialog when the file is dropped onto its window.

Confirmed on
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061113 Minefield/3.0a1
Debian testing, Xorg 7.0 mixed.
kkbswitch layout switcher still works when all other X UI is hung.

Comment 2

11 years ago
WFM, sort of, with Gnome and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/0000000000 Firefox/2.0.0.4 (Ubuntu-edgy).

The window behavior was a little weird, but I was able to get out of it, and the X server didn't freeze.  When I drag a binary file from the Save As dialog box into the Fx window, a Fx "Opening..." dialog box opens up asking how to deal with it, as I would expect.  However, neither of the two buttons ("Cancel" and "Save File") in that dialog box work, and I can't close that dialog box with the "X" button in the upper right corner.  I can, however, click on the Cancel button in the Save As dialog box, and then the buttons in the "Opening..." dialog box both work.  

If, instead of a binary file, I drag a text file from the Save As dialog box, Fx displays it.

Could this have been, at least partially, an issue with the then-current (but now older) version of Gnome?

Reporter, can you verify whether you still see the problem with the most recent version of Firefox?  If you can still reproduce it, what version of Gnome are you using?

Comment 3

11 years ago
Sorry, that wasn't with an official build.  Tested again with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/2007051502 Firefox/2.0.0.4, and the results were the same.  None of the buttons or drop-downs in the "Opening..." dialog did anything until the "Save As" dialog was closed, but the X server didn't freeze.
Patrick or Aleksej, can you still reproduce this?
Whiteboard: CLOSEME - 06/25

Comment 5

11 years ago
Reproduced (same way as in comment #1) on Debian 4.0 (Xorg 7.1.0, libgtk2.0-0 2.8.20) with
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070611 Minefield/3.0a6pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5pre) Gecko/20070611 BonEcho/2.0.0.5pre

not with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.13pre) Gecko/20070611 Firefox/1.5.0.13pre
Whiteboard: CLOSEME - 06/25

Comment 6

11 years ago
WFM with
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a9pre) Gecko/2007102904 Minefield/3.0a9pre
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

Also, no dialog appears, so I suppose it was not a duplicate of bug 100180.

Patrick or anyone, is this still reproducible with the latest builds of Firefox?
Whiteboard: CLOSEME 11/30

Comment 7

11 years ago
PS: comment #6 is on Debian GNU/Linux “lenny” testing.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007102904 Minefield/3.0a9pre
Gentoo, Xorg 7.2 (mixed), xorg-server 1.3.0.0

X didn't hangs, but there is other bugs, such as drag'n'dropping something in bookmarks menu makes that menu become visible until closing modal.
(Reporter)

Comment 9

11 years ago
Haven't been able to reproduce using Ubuntu (or with KDE) Gutsy.  I'll try again on my Debian testing box when I'm home but I haven't encountered this bug for quite a while.

Very likely was an old GNOME (File selector dialog) issue, and the problem is gone in the latest Gnome release.

Comment 10

11 years ago
Resolving as WFM per comment 6 and comment 9.  Reporter, feel free to re-open this bug in the event that you see this behavior with the latest Firefox 3 beta.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.