Bugzilla module crashes with bug, bug-total, and bugs commands

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Achindra.Bhatnagar, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1) Gecko/20061010 SUSE/1.5.0.6-1.3 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1) Gecko/20061010 SUSE/1.5.0.6-1.3 Firefox/2.0


I sent a message to irc with a bug number and MozBot left the chat and joined again. Bugzilla module of MozBot crashed. 

Module Bugzilla: failed to shutdown cleanly

Reproducible: Always

Steps to Reproduce:
1. load Bugzilla module
2. send a message with as bug <bug_number>




2006-11-14 05:35:26 UTC (18328) Told:  <Achindra_> bug 62612
2006-11-14 05:35:26 UTC (18328) Module Bugzilla: spawned 18395 (wget --quiet --passive --user-agent="Mozilla/5.0 (compatible; mozbot)" --output-document=- http://localhost:2032/buglist.cgi?bug_id=62612)
2006-11-14 05:35:26 UTC (18328) child 18395 completed URI
2006-11-14 05:35:26 UTC (18395) Module Bugzilla: failed to shutdown cleanly!!! Insecure dependency in exec while running with -T switch at ./mozbot.pl line 1497.
2006-11-14 05:35:26 UTC (18395) perl is shutting down...
2006-11-14 05:35:26 UTC (18395) Module Infobot: garbage collected
2006-11-14 05:35:26 UTC (18395) Module Bugzilla: garbage collected
2006-11-14 05:35:26 UTC (18395) Module XMLLogger: garbage collected
2006-11-14 05:35:26 UTC (18395) Module Wishlist: garbage collected
2006-11-14 05:35:26 UTC (18395) Module Quiz: garbage collected
2006-11-14 05:35:26 UTC (18395) Module Parrot: garbage collected
2006-11-14 05:35:26 UTC (18395) Module MiniLogger: garbage collected
2006-11-14 05:35:26 UTC (18395) Module MagicEightBall: garbage collected
2006-11-14 05:35:26 UTC (18395) Connection: garbage collected
2006-11-14 05:35:26 UTC (18395) Module List: garbage collected
2006-11-14 05:35:26 UTC (18395) Module Infobot: garbage collected
2006-11-14 05:35:26 UTC (18395) Module Admin: garbage collected
2006-11-14 05:35:26 UTC (18395) Module General: garbage collected
2006-11-14 05:35:26 UTC (18395) Module FortuneCookies: garbage collected
2006-11-14 05:35:26 UTC (18395) Module Karma: garbage collected
2006-11-14 05:35:26 UTC (18395) Module Greeting: garbage collected
2006-11-14 05:35:26 UTC (18395) Connection: garbage collected
2006-11-14 05:35:26 UTC (18328) child 18395 exited.
2006-11-14 05:35:26 UTC (18328) ->Achindra_: Zarro boogs found.
2006-11-14 05:35:26 UTC (18328) eek! disconnected from network
2006-11-14 05:35:26 UTC (18328) Module Bugzilla: garbage collected
2006-11-14 05:35:26 UTC (18328) Module XMLLogger: garbage collected
2006-11-14 05:35:26 UTC (18328) Module Wishlist: garbage collected
2006-11-14 05:35:26 UTC (18328) Module Quiz: garbage collected
2006-11-14 05:35:26 UTC (18328) Module Parrot: garbage collected
2006-11-14 05:35:26 UTC (18328) Module MiniLogger: garbage collected
2006-11-14 05:35:26 UTC (18328) Module MagicEightBall: garbage collected
2006-11-14 05:35:26 UTC (18328) Module List: garbage collected
2006-11-14 05:35:26 UTC (18328) Module Karma: garbage collected
2006-11-14 05:35:26 UTC (18328) Module Greeting: garbage collected
2006-11-14 05:35:26 UTC (18328) Module General: garbage collected
2006-11-14 05:35:26 UTC (18328) connecting to sandbox1:6667...
(Reporter)

Updated

12 years ago
Severity: normal → major

Comment 1

12 years ago
What version of Perl, Mozbot, Net::IRC and Wget?

It sounds like wget is hanging, judging by how "late" the spawned child exits, but I could be offbase there.
(Reporter)

Comment 2

12 years ago
Perl: v5.8.5
MozBot: 2.4
NET::IRC 0.70

Wget: 1.9

I guess you are right about wget!
I tried this manually on command line,

wget http://localhost:2032/bugzilla/show_bug.cgi?id=62465
--09:58:26--  http://localhost:2032/bugzilla/show_bug.cgi?id=62465
           => `show_bug.cgi?id=62465'
Resolving localhost... 127.0.0.1
Connecting to localhost[127.0.0.1]:2032... failed: Connection refused.

I access my bugzilla through a port forward tunnel to the gateway server.

I turned on the ssh tunnel and tried again and wget succeeded. Then I retried on channel and history repeated itself!



============================

2006-11-18 04:53:05 UTC (28483) Heard: #junta <Achindra_> bug 62671 is duplicate of bug 61554
2006-11-18 04:53:05 UTC (28483) Module Bugzilla: Noticed someone mention bug 62671 -- investigating...
2006-11-18 04:53:05 UTC (28483) Module Bugzilla: Noticed someone mention bug 61554 -- investigating...
2006-11-18 04:53:05 UTC (28483) Module Bugzilla: spawned 28486 (wget --quiet --passive --user-agent="Mozilla/5.0 (compatible; mozbot)" --output-document=- http://localhost:2032/buglist.cgi?bug_id=62671,61554)
2006-11-18 04:53:06 UTC (28486) Module Bugzilla: failed to shutdown cleanly!!! Insecure dependency in exec while running with -T switch at ./mozbot.pl line 1497.
2006-11-18 04:53:06 UTC (28486) perl is shutting down...
2006-11-18 04:53:06 UTC (28486) Module Bugzilla: garbage collected
2006-11-18 04:53:06 UTC (28486) Module Parrot: garbage collected
2006-11-18 04:53:06 UTC (28486) Module Wishlist: garbage collected
2006-11-18 04:53:06 UTC (28486) Module God: garbage collected
2006-11-18 04:53:06 UTC (28486) Module MiniLogger: garbage collected
2006-11-18 04:53:06 UTC (28483) child 28486 completed URI
2006-11-18 04:53:06 UTC (28486) Module MagicEightBall: garbage collected
2006-11-18 04:53:06 UTC (28486) Module List: garbage collected
2006-11-18 04:53:06 UTC (28486) Module Infobot: garbage collected
2006-11-18 04:53:06 UTC (28486) Module Karma: garbage collected
2006-11-18 04:53:06 UTC (28486) Module Greeting: garbage collected
2006-11-18 04:53:06 UTC (28486) Module General: garbage collected
2006-11-18 04:53:06 UTC (28486) Module Admin: garbage collected
2006-11-18 04:53:06 UTC (28486) Connection: garbage collected
2006-11-18 04:53:06 UTC (28483) child 28486 exited.
2006-11-18 04:53:06 UTC (28483) eek! disconnected from network
2006-11-18 04:53:06 UTC (28483) Module Bugzilla: garbage collected
2006-11-18 04:53:06 UTC (28483) Module Parrot: garbage collected
2006-11-18 04:53:06 UTC (28483) Module God: garbage collected
2006-11-18 04:53:06 UTC (28483) Module Wishlist: garbage collected
2006-11-18 04:53:06 UTC (28483) Module MiniLogger: garbage collected
2006-11-18 04:53:06 UTC (28483) Module MagicEightBall: garbage collected
2006-11-18 04:53:06 UTC (28483) Module List: garbage collected
2006-11-18 04:53:06 UTC (28483) Module Karma: garbage collected
2006-11-18 04:53:06 UTC (28483) Module Greeting: garbage collected
2006-11-18 04:53:06 UTC (28483) Module General: garbage collected
2006-11-18 04:53:06 UTC (28483) connecting to sandbox1:6667...
2006-11-18 04:53:06 UTC (28483) connected! woohoo!
========================================
(Reporter)

Comment 3

12 years ago
I found, somewhere in the code my baseURL is getting changed from 

http://localhost:2032/bugzilla/ to http://localhost:2032/

(wget --quiet --passive --user-agent="Mozilla/5.0 (compatible; mozbot)" --output-document=- http://localhost:2032/buglist.cgi?bug_id=62671)

Can you point as if how do I stop this from happening. I guess, then the code will succeed!
(Reporter)

Comment 4

12 years ago
I resolved the URL issue from the config file, but am still getting that error!

====================================
2006-11-18 06:16:08 UTC (28641) Heard: #junta <Achindra_> bug 62614
2006-11-18 06:16:08 UTC (28641) Module Bugzilla: Noticed someone mention bug 62614 -- investigating...
2006-11-18 06:16:08 UTC (28641) Module Bugzilla: spawned 28653 (wget --quiet --passive --user-agent="Mozilla/5.0 (compatible; mozbot)" --output-document=- http://localhost:2032/bugzilla/buglist.cgi?bug_id=62614)
2006-11-18 06:16:11 UTC (28641) child 28653 completed URI
2006-11-18 06:16:11 UTC (28653) Module Bugzilla: failed to shutdown cleanly!!! Insecure dependency in exec while running with -T switch at ./mozbot.pl line 1497.
2006-11-18 06:16:11 UTC (28653) perl is shutting down...
=====================================

When I run the following on commandline, 
wget --quiet --passive --user-agent="Mozilla/5.0 (compatible; mozbot)" --output-document=- http://localhost:2032/bugzilla/buglist.cgi?bug_id=62614


I get the html code for the whole page <bugzilla>
(Reporter)

Comment 5

12 years ago
Any updates on this?

Comment 6

12 years ago
you want to chase the taint / insecure dependency
(Reporter)

Comment 7

12 years ago
I want this module to run on my machine. 
If you can provide me with a pointer, I can take lead from there to try debug this. 

Updated

10 years ago
Assignee: ian → nobody

Comment 8

10 years ago
Haven't seen other reports of this, if its still a problem and you can provide more steps to help reproduce, reopen, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE

Updated

10 years ago
Resolution: INCOMPLETE → WORKSFORME
Achindra: Can you still reproduce this error on the latest trunk version of Mozbot?
Verified Worksforme, since no new information.  If anyone can reproduce the bug, then we will reopen.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.