Automatically switch dictionary language from Content-Language header

RESOLVED DUPLICATE of bug 338427

Status

()

enhancement
RESOLVED DUPLICATE of bug 338427
13 years ago
13 years ago

People

(Reporter: francois, Assigned: mscott)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I write here for Firefox 2.0 new spell checker. When several language dictionaries are installed, and the user browses the web and writes in several languages, he must manually switch the language with a right-click in the form field, every time the language changes.

It would be nice that be done automatically. I think it is pretty safe to assume that the user will write in English on a page in English, write in French on a page written in French, and so forth.

Finding the language of a given web page is not trivial, there is however often an easy way:

1) Look the Content-Language HTTP header:
Content-Language: fr

2) Or the corresponding meta tag in the the HTML <head>:
<meta http-equiv="Content-Language" content="fr">

If no Content-Language is found, then use the default language.

Reproducible: Always

*** This bug has been marked as a duplicate of 338427 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.