Closed Bug 360721 Opened 15 years ago Closed 15 years ago

On startup updated extension download fails - proxy password not prompted for

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 312473

People

(Reporter: occam, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

Connecting to the internet via an authenticating proxy, I find that the EM identifies updates when Firefox is started, but it always fails to download them.

Clicking on continue, I am then prompted for my userid/password, and I can then go to Tools/Add-ons and download the updates manually.

It seems to me that the EM should prompt for the userid/password before attempting the download.

This happens every time an update is found when starting Firefox.

Reproducible: Always

Steps to Reproduce:
1. Start firefox connecting using proxy.utas.edu.au as proxy
2. Say to download identified updates
3. Download fails, click on continue
4. Enter userid/password when prompted
5. Can download updates from Tools/Add-ons



Expected Results:  
1. Start firefox connecting using proxy.utas.edu.au as proxy
2. Say to download identified updates
3. Get prompted for userid/password
4. Components updated

*** This bug has been marked as a duplicate of 312473 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.