Firebox locks up (not responding) with either Googlebar lite and Google toolbar loaded

RESOLVED INCOMPLETE

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED INCOMPLETE
11 years ago
11 years ago

People

(Reporter: Allen Edwards, Unassigned)

Tracking

({hang})

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14, URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Randon lockup with hour glass showing and "not responding" on titlebar.  This has previously been reported when I was using Google Toolbar and I was told this is not a Firefox bug.  I switched to Googlebar Lite as it was reported to solve this problem but the browser is locking up about 1/day (less than with Google Toolbar).

It does not lock up when these plugins are not loaded.  As the plugins worked with firefox 1.5 and both toolbars lock up, it seems to me that there is a bug in Firefox 2.0 and if you all don't believe it, you are in denial.

Reproducible: Sometimes

Steps to Reproduce:
1.Firefox locks up when clicking on something (today it was just on a page, not a link).  
2.Becomes non responsive.
3.Happens about once a day

Actual Results:  
After it locks up, nothing works, buttons don't respond, very difficult to close application

Expected Results:  
it should not have locked up
That's not denial, it's the rules of the game: we're more than willing to work with extension developers to help them find the causes of problems in their extensions, and to try to fix bugs they trigger, but since we have no control over their code, we're not going to debug it and work around their bugs in Firefox/Core code, only to have them change their code without us even knowing about it. I'm sorry that you as an individual user don't have any course of action other than telling the extension authors about their bug, but that's how it is, and filing the same bug over and over here isn't going to change that.

*** This bug has been marked as a duplicate of 359954 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

11 years ago
I am not filing the same bug.  This is a new bug.  Google Toolbar and Googlebar lite are completely different products made by completely different people.  They both work with Firefox 1.5 and neither work with 2.0.  Googlebar lite is some clone of Google Toolbar.  Doesn't it seem strange that two completely different program suddenly have bugs they didn't have before when the main program changes.  Clearly something changed in Firefox 2.0 that is causing the bug in these two different programs.  I have seen lots of people with this problem so am sure it isn't just my system.  I have managed large software teams in the past, which is why I made the comment about denial.  Not trying to be rude, just the way I see it.

(In reply to comment #1)
> That's not denial, it's the rules of the game: we're more than willing to work
> with extension developers to help them find the causes of problems in their
> extensions, and to try to fix bugs they trigger, but since we have no control
> over their code, we're not going to debug it and work around their bugs in
> Firefox/Core code, only to have them change their code without us even knowing
> about it. I'm sorry that you as an individual user don't have any course of
> action other than telling the extension authors about their bug, but that's how
> it is, and filing the same bug over and over here isn't going to change that.
> 
> *** This bug has been marked as a duplicate of 359954 ***
> 

Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

11 years ago
Unless this is reduced to a test case I don't see any reason to presume it's not the same issue that is effecting 359954.  These are extensions and Mozilla makes no guarantee as to the effects they might have on browser stability or performance.

My vote is that if it's not a dupe of 359954 it's invalid.
(Reporter)

Comment 4

11 years ago
It acts like it is some kind of race condition, timing related or something.  My impression is that it is more likely if I click on several things, like when I change my mind what link I want to follow.  Very difficult to turn into a test case.  There are lots of toolbar users who will probably give up on this product if this isn't fixed, IMO.  How can I help isolate the problem?

(In reply to comment #3)
> Unless this is reduced to a test case I don't see any reason to presume it's
> not the same issue that is effecting 359954.  These are extensions and Mozilla
> makes no guarantee as to the effects they might have on browser stability or
> performance.
> 
> My vote is that if it's not a dupe of 359954 it's invalid.
> 

Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Reporter, do you still see this problem with the latest Firefox 2 and the latest google toolbars? If not, can you please close this bug as WORKSFORME. Thanks!
Keywords: hang
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch
(Reporter)

Comment 6

11 years ago
I have no idea if this is why firefox still hands, which it does.  I just restart the thing.  I will close the bug as nobody picked it up and I have lost interest.  I marked incomplete because there is no "I give up, just close it" box to check and incomplete is undefined so what the heck, closest to how I feel about this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INCOMPLETE
Does it hang if you use a new firefox profile?
- http://kb.mozillazine.org/Profile_manager
(Do not delete your existing one)

If it does not, this will tell us the hanging is probably due to an extension, theme, or user-setting.
You need to log in before you can comment on or make changes to this bug.