Re-examine zoom logic on trunk/Gecko 1.9 after reflow branch landing (implement shrink-to-fit)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
12 years ago
4 years ago

People

(Reporter: alqahira, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
PowerPC
Mac OS X

Details

torben and hwaara talked in bug 155956 about several bits of the zoom logic that will need to re-examined once the reflow branch lands on the trunk.

I don't pretend to know what those bits were, so I hope they'll (re-)add the specifics here.
Bug 155956 comment 72:

> On the 1.8 branch no XPCOM interface changes are allowed.

I suggest we just drop the core changes for now. This means that the width
won't shrink upon zooming ("de-zooming" works fine) but I would assume zooming
is mostly used when the window is too small anyway. As a bonus the
force-resize-after-reflow hack (in windowShouldZoom) can be removed.

This bugged me when playing with zoom today.  If we still need Gecko methods to get us info for that (and other bits) after the reflow branch, we should see about getting them in during Gecko 1.9 alpha stage (and file appropriate bugs to do so).  I don't pretend to follow the entire discussion in bug 155956, so I have no idea if they'll be needed or not.
Reflow landed today (bug 300030)
Summary: Re-examine zoom logic once reflow branch lands → Re-examine zoom logic on trunk/Gecko 1.9 after reflow branch landing
Duplicate of this bug: 366997

Comment 4

10 years ago
This is way over my head, but for anyone with the Gecko mojo, I think the best way would be to get the BrowserView's nsIDOMWindow, summon the nsIFrame of the content, and call GetMinWidth/GetPrefWidth on it, as explained at https://wiki.mozilla.org/Gecko:Reflow_Refactoring#Intrinsic_Sizing . Don't know what to do about the height calculation.
Unless someone steps up (see comment 4), this is not a 2.0 bug anymore.
Target Milestone: Camino2.0 → ---

Updated

9 years ago
Summary: Re-examine zoom logic on trunk/Gecko 1.9 after reflow branch landing → Re-examine zoom logic on trunk/Gecko 1.9 after reflow branch landing (implement shrink-to-fit)

Updated

9 years ago
Duplicate of this bug: 499771
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.