tr_install.pl won't create the tables

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: bugzilla.mozilla.org, Assigned: gregaryh)

Tracking

Other
Other

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; SBS; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: http://landfill.bugzilla.org/testopia/testopia-1.1-beta.tar.gz

When I try to install testopia 1.1 on bugzilla 2.22.1 with the commandline "perl tr_install.pl -nopatch" I get the following output:

Now installing Testopia ...

Skip patching Bugzilla's files.

Setting file permissions ...
Done.

Checking Testopia database ...
Building Schema object from database...
Initializing the new Schema storage...
Adding new column case_id to table test_case_bugs ...
DBD::mysql::db do failed: Table 'bugs2.test_case_bugs' doesn't exist at Bugzilla/DB.pm line 373
        Bugzilla::DB::bz_add_column('Bugzilla::DB::Mysql=HASH(0x69c588)', 'test_case_bugs', 'case_id', 'HASH(0x7fa3e4)') called at tr_install.pl line 307
        main::UpdateDB('Bugzilla::DB::Mysql=HASH(0x69c588)', 1) called at tr_install.pl line 79


Reproducible: Always

Steps to Reproduce:
1. Install Bugzilla 2.22.1
2. perl tr_install.pl -nopatch
Actual Results:  
The tables aren't created

Expected Results:  
The database are created
(Reporter)

Updated

12 years ago
Version: unspecified → 1.1

Comment 1

12 years ago
If your 'steps to reproduce' are accurate, then this is guaranteed to fail since the files did not get patched.

Since tr_install.pl does not know how to patch 2.22.1, please patch manually. Here are instructions:

cd <docroot>/testopia
download https://bugzilla.mozilla.org/attachment.cgi?id=245657
rename the downloaded file "patch-2.22.1"
cd <docroot>
patch -p2 -i testopia/patch-2.22.1
./tr_install.pl -nopatch

Comment 2

12 years ago
holzhaeuer -- any news on this?
(Reporter)

Comment 3

12 years ago
it works now. thanks.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 4

12 years ago
i have run into the exact same problem - tables are not created after tr_install. mysql version is 5.0.27-community-nt. here's the output:

==========================================================
C:\bugzilla>perl tr_install.pl
Now installing Testopia ...

Patch already run successfully. Skipping.

Setting file permissions ...
Running on Windows or Cygwin... skipping permissions...
Done.

Checking Testopia database ...
Adding new column case_id to table test_case_bugs ...
DBD::mysql::db do failed: Table 'weevil.test_case_bugs' doesn't exist at Bugzill
a/DB.pm line 373
        Bugzilla::DB::bz_add_column('Bugzilla::DB::Mysql=HASH(0x23a8830)', 'test
_case_bugs', 'case_id', 'HASH(0x23b154c)') called at tr_install.pl line 301
        main::UpdateDB('Bugzilla::DB::Mysql=HASH(0x23a8830)') called at tr_insta
ll.pl line 68
==========================================================
You need to log in before you can comment on or make changes to this bug.