Default Client options disabled after making TB the default mail or news client (system integration dialog)

RESOLVED FIXED in Thunderbird 19.0

Status

Thunderbird
OS Integration
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: Magnus Melin, Assigned: aceman)

Tracking

Trunk
Thunderbird 19.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

11 years ago
Use the Preferences General > "Check now" button to bring up the Default Client dialog. Check E-mail and Newsgroups and hit OK.

Now (or later after restart) come back and click "Check now" again. The E-mail and Newsgroups options are now grayed out for some reason. (If you have it set to check for default on startup the options are also disabled.)

So if you ever check it you are unable to unset thunderbird as default.
(Reporter)

Comment 1

11 years ago
Created attachment 245674 [details]
screenshot after making default news client

BTW, This is Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061115 Thunderbird/2.0b1pre ID:2006111503 and also todays trunk btw.
It took me an embarrassingly long time to realize that this is a UI issue (since I'm pretty sure we don't want to be the only email client on any platform that anyone's ever seen that implements "give your system no default email client" and implementing UI to set another client as default would only be proper platform behavior on OS X, where the UI to choose defaults for browser and mail are in Safari's and Mail.app's prefs, not in an OS control panel), and that embarrassingly long time makes me think it's a real UI issue. 

If we just had labels saying "Thunderbird is set as your default email client" and "Thunderbird is set as your default news client" then I'd probably realize right off that to change that, I need to either open some other program and set it as default, or use "Preferred Applications" or "Set Program Access and Defaults", but having a disabled checkbox just screams "you could uncheck me, if only you could figure out why I'm disabled, you dummy."
(Reporter)

Updated

9 years ago
Assignee: mscott → nobody
(Reporter)

Comment 3

9 years ago
Created attachment 324760 [details] [diff] [review]
ui patch to skip the disabling

Unfortunately, there seems to be no (toolkit) way to unset as default client :(

Comment 4

7 years ago
I too was tripped up by this, only as of 3.1.3 this includes RSS feeds as well.  Mac OS X.
OS: Linux → All
Hardware: x86 → All

Comment 5

7 years ago
Comment on attachment 324760 [details] [diff] [review]
ui patch to skip the disabling

HELP!!!!! I just want to stop thunderbird being my default email reader - what do I do with this patch
Attachment #324760 - Flags: review?(bienvenu)
Comment on attachment 324760 [details] [diff] [review]
ui patch to skip the disabling

sorry for the noise
Attachment #324760 - Flags: review?(bienvenu)

Comment 7

7 years ago
Created attachment 484833 [details]
screenshot of "locked-on" mac thunderbird default email
Magnus, are you interested in finishing this off?
(Reporter)

Comment 9

6 years ago
No, i don't think so.
(Assignee)

Comment 10

5 years ago
I encountered this too while working on bug 476426. As already mentioned, there is currently no way to unset TB as the default client. The shell-service has no such method. So the disabling is intentional to show the user he can't remove it. The existing UI patch here is useless without the backend part.

It is probably needed to run other client and make that one the default from inside it. Or use the Windows built-in controls.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 567579
(Assignee)

Comment 12

5 years ago
From reading other bugs and comments it looks like coding the "unset itself as default client" method (for shell service) is quite hard (at least on Windows). So we can't expect it to be done soon.

Bwinton, what about showing an info bar in the dialog to inform the user about that. Like this:
"If you want to set a different application as the default client, start that application and use 'Set default' action from inside it."
Component: Preferences → OS Integration
Summary: Default Client options disabled after making default news client → Default Client options disabled after making TB the default mail or news client (system integration dialog)
I'm not a fan of the info bar.  (In general, people don't read stuff. ;)

Perhaps we could change the list of checkboxes to a list of buttons?  "Set as default mail client", "Set as default news client", and then if it's already set, have text in the same place saying "Thunderbird is your default rss client."?
(Assignee)

Comment 14

5 years ago
Yeah, but then if the unsetting gets implemented we'd need to redo the dialog again, maybe back to what it is now ;)

What about a tooltip showing when hovering over a disabled item?

Yes, the dialog is also used as a way to check the defaults so we need to preserve that functionality. It must not be a one way button to set the defaults. So what you propose is OK. The buttons just won't be so nice visually :)
(Assignee)

Comment 15

5 years ago
If we rework the dialog in such dramatic way, then the buttons in bug 476426 will get a different meaning again :)
Assignee: nobody → acelists
Does any other email client have an "un-set me" option?  (And if so, what does it do in that case?)
(Assignee)

Comment 17

5 years ago
No, I don't know any. Maybe it is not possible?
Sure, let's see what the tooltip looks like.

Thanks,
Blake.
(Assignee)

Comment 19

5 years ago
Created attachment 673731 [details] [diff] [review]
patch

The tooltip will appear only on items that are disabled.
Attachment #324760 - Attachment is obsolete: true
Attachment #673731 - Flags: ui-review?(bwinton)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Comment on attachment 673731 [details] [diff] [review]
patch

>+++ b/mail/locales/en-US/chrome/messenger/systemIntegrationDialog.dtd
>@@ -6,13 +6,15 @@
>+<!ENTITY unsetDefault.tooltip "It is not possible to unset &brandShortName; as the default client from this dialog. To set another application as the default client you must start that application and use its 'Set as default' dialog, or use the Operating system built-in tool.">

Okay, the tooltip doesn't seem horrible, but the text is longer than I think is reasonable for a tooltip, so I'll say ui-r=me, with shorter text.  How about something along the lines of:
It is not possible to unset &brandShortName; as the default client within &brandShortName;. To make another application the default you must use its 'Set as default' dialog.

(That new text brings the tooltip down to two lines, which seems much better to me. ;)

Thanks,
Blake.
Attachment #673731 - Flags: ui-review?(bwinton) → ui-review+
(Assignee)

Comment 21

5 years ago
Created attachment 676267 [details] [diff] [review]
patch v2
Attachment #673731 - Attachment is obsolete: true
Attachment #676267 - Flags: review?(mconley)
Comment on attachment 676267 [details] [diff] [review]
patch v2

Review of attachment 676267 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with nit fixed. Thanks aceman!

::: mail/base/content/systemIntegrationDialog.js
@@ +48,2 @@
>      }
> +    if (!this._mailCheckbox.disabled)

Nit - I generally like a newline after a block.
Attachment #676267 - Flags: review?(mconley) → review+
(Assignee)

Comment 23

5 years ago
Created attachment 683244 [details] [diff] [review]
patch v3

Ok.
Attachment #676267 - Attachment is obsolete: true
Attachment #683244 - Flags: review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/2e2fb5a70778
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 19.0
You need to log in before you can comment on or make changes to this bug.