random crash, usually before 5 minutes surfed

RESOLVED DUPLICATE of bug 304370

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 304370
11 years ago
11 years ago

People

(Reporter: Kevin Hunter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)

No clue.  I usually have more than 1 tab open, and it crashes instantly, with no attempt to do the Talkback agent.  The crash is instantaneous.  I'm used to crashes holding for a couple of seconds, either as recursive functions run amok, or as the harddrive gets flooded.  With this crash, I surf, and any-and-all Firefox windows just disappear, no harddrive activity, no notes, no messages, nothing.

Reproducible: Always

Steps to Reproduce:
1. Surf for five minutes, using multiple tabs.
2. Just after you open a link, it'll sometimes crash.
Actual Results:  
Firefox crashes frequently and seemingly randomly.

Expected Results:  
Urm  . . . shouldn't crash?!  Perhaps you could let interested users know why the site is incorrect or something?

kevin@lina  4:52 PM Wed, 15 Nov 2006 EST, J: 0, H: 767, C: 4
~
$: firefox -safe-mode --sync
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 118 error_code 8 request_code 142 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

kevin@lina  4:53 PM Wed, 15 Nov 2006 EST, J: 0, H: 768, C: 5
~
$: 

I noticed last night that it kept crashing when I tried to check or send messages through the Facebook site.

Comment 1

11 years ago
sounds like flash. please read about flash crashing in bugzilla
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> sounds like flash. please read about flash crashing in bugzilla

Can you give me a pointer to some documentation?

I have not installed any Flash yet.  however, heading to a known Flash using site does seem to confirm what you're saying.

Although, to be honest, it seems strange to me that it's acceptable that a plugin is "allowed" to crash Firefox.  Please correct me if I'm wrong, but doesn't a crash mean that it's unconditionally an issue with Firefox?

Comment 3

11 years ago
User reports that this happens on sites with flash, dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 304370
> Although, to be honest, it seems strange to me that it's acceptable that a
> plugin is "allowed" to crash Firefox.  Please correct me if I'm wrong, but
> doesn't a crash mean that it's unconditionally an issue with Firefox?

FYI
The plugins are running as thread in the same process space as Gecko and a crashing plugin will also always crash Gecko.

You need to log in before you can comment on or make changes to this bug.