Can't distinguish long search suggestions

RESOLVED DUPLICATE of bug 339363

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 339363
11 years ago
11 years ago

People

(Reporter: brian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
The search field is too narrow to allow users to read search suggestions beyond a single short word. This is problematic when the suggestions all share the same first word, but differ on their second/third/etc. words. Effectively this makes the search suggestions meaningless most of the time.

To reproduce this bug, type a few words into the search bar, such as 'firefox search' and notice how none of the suggestions are distinguishable.

A simple solution to this problem is to make the dividing space between the location field and the search widgets horizontally draggable. Then when users need to see longer search suggestions, they can just enlarge the search field.

Updated

11 years ago
Severity: normal → enhancement
OS: Windows 2000 → All
Hardware: PC → All

*** This bug has been marked as a duplicate of 205011 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

11 years ago
Bug 205011 is long rambling mess of people clamouring for a resizable search bar for typing in longer searches.

This bug about search suggestions being indistinguishable is a more severe problem, since it renders a firefox feature unusable.

Although I proposed a solution similar to the feature requested in bug 205011, the problem being addressed is different. The bugs are related, but not duplicates. So, in the hopes of avoiding having this usability issue depend on that other bug's multi-year debate, I'd like to propose a new solution:

Have the search suggestion drop-down resize to its preferred width and either have it hang off the window edge, or right align it where it is and let its left edge extend as necessary.

This will allow a quick fix to this more severe problem, while bug 205011 continues the long debate on whether/how to resize the bar itself.

Reopening for now. Phil or others, if you disagree refile as duplicate...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Divider between location field and search bar should be draggable → Can't distinguish long search suggestions
(Reporter)

Updated

11 years ago
Severity: enhancement → normal

*** This bug has been marked as a duplicate of 339363 ***
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Component: Toolbars → Search
QA Contact: toolbars → search
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.