Closed Bug 361048 Opened 15 years ago Closed 15 years ago

Switching from Account Central to folder does not scroll to newest message

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: neil, Assigned: neil)

References

Details

(Keywords: fixed-seamonkey1.1, regression, Whiteboard: [verified-seamonkey1.1])

Attachments

(1 file)

Please bear with me on this, it's a bit tricky to explain. The effect relies on certain fairly common settings. First you will need a folder without a selected message, or you need to disable the last selected message pref. The folder also needs to be sorted by date or order received (or thread). In these circumstances when you open the folder it should scroll to the very end of the message list.  You also need to show the message pane by default. The problem arises when you were previously viewing Account Central. In this case although it is hidden the thread tree still has the "full" height of the window. When you then switch to the aforementioned folder the thread tree is resized but it does not update internally until the next reflow. This makes it scroll based on its old size meaning that some of the newest messages are not actually visible.
Attached patch Proposed patchSplinter Review
Assignee: mail → neil
Status: NEW → ASSIGNED
Attachment #245830 - Flags: review?(mnyromyr)
Comment on attachment 245830 [details] [diff] [review]
Proposed patch

>Index: mailWindow.js
>===================================================================
>+    if (!threadPaneSplitter.hidden && threadPaneSplitter.getAttribute("state") != "collapsed") {
>         GetMessagePane().collapsed = false;

Since bracket style (and indentation) in this file are quite inhomogeneous, I'm in favour of using the overall prevalent style ie. no brackets at the end of line...

r=me either way.
Attachment #245830 - Flags: review?(mnyromyr) → review+
Attachment #245830 - Flags: approval-seamonkey1.1?
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Comment on attachment 245830 [details] [diff] [review]
Proposed patch

first a=me for SM1.1
Comment on attachment 245830 [details] [diff] [review]
Proposed patch

a=me for SeaMonkey 1.1
Attachment #245830 - Flags: approval-seamonkey1.1? → approval-seamonkey1.1+
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.1pre) Gecko/20061122 SeaMonkey/1.1b] (nightly) (W98SE)

V.Fixed on MOZILLA_1_8_BRANCH, between these two builds.

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.1pre) Gecko/20061123 SeaMonkey/1.1b] (nightly) (W98SE)

*****

Would Thunderbird need the same fix ?
From a code point of view, it seems it could.
(Else, why would this work in TB and not in SM ?)
Whiteboard: [verified-seamonkey1.1]
(In reply to comment #6)
>Would Thunderbird need the same fix ?
Apparently it already has its own bug filed for this.
(In reply to comment #7)
> (In reply to comment #6)
> >Would Thunderbird need the same fix ?
> Apparently it already has its own bug filed for this.

Bug 321551.  I finally got around to porting this patch over, hopefully not too late for TB 2.0.
You need to log in before you can comment on or make changes to this bug.