Opening extension's home page from extension auto update window overwrites session

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
12 years ago
5 years ago

People

(Reporter: torhu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

This happens when using the automatic extension updater that starts at Firefox startup, before the main window is opened.

When there is a new version of an extension, I often go to the home page to read the changelog before I install it.  Then I close the home page and install the updated extension.

The problem is that when I click on 'Continue' after installing the updated extension, the extension's home page is loaded, instead of my previous session.  So I have lost it all, and have to recover it using my memory and the browser's history feature.

Reproducible: Always

Steps to Reproduce:
1. Start firefox
2. If firefox shows the extension autoupdater with a new version of any of your extensions, open the extension's home page.
3. Close extension's home page.  (don't know if this matters)
4. Install the extension, and click 'continue'.
Actual Results:  
If you have chosen to restore your previous session at startup, Firefox now restores your session.  Which consists of the page you opened in step 2 above.

Expected Results:  
My real previous session should have been restored instead.
Update notification was done on startup for 2.0 as a temporary measure to provide update notification and this will be fixed after there is an app notification widget as in bug 347585
Depends on: 347585
No longer depends on: 347585

Updated

12 years ago
Duplicate of this bug: 371001

Updated

12 years ago
Duplicate of this bug: 371373

Updated

12 years ago
Component: Extension/Theme Manager → Session Restore
QA Contact: extension.manager → session.restore
The option to open a browser window during startup update notification via the context menu for the homepage and the about dialog has been removed in bug 348419. So, this bug should now be fixed by the checkin of bug 348419. Resolving duplicate of bug 348419.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348419
Target Milestone: --- → Firefox 3 M7

Comment 5

10 years ago
So, this bug still exists with a slight modification of step #2:
2. If firefox shows the extension autoupdater with a new version of any of your
extensions, _install the update and then_ open the extension's home page.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Target Milestone: Firefox 3 alpha7 → ---

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Duplicate of this bug: 417774

Updated

9 years ago
Duplicate of this bug: 501303

Comment 8

9 years ago
this bug is really annoying. It's been present since Firefox 2 (2006) and just caused me to lose about 20 tabs I wanted saved (incidentally, I was restarting Firefox to reset its memory use - which is still high when I open, read & then close tabs - an operation I typically have to do every 2 days or so).

Any chance of special-casing the plug-ins home-page dialog (perhaps creating a temporary profile for a separate instance), while the new application notification widget still isn't released?

Updated

8 years ago

Comment 9

5 years ago
Does this still reproduce for you?
Flags: needinfo?(torhu)
Flags: needinfo?(bolsh)
(Reporter)

Comment 10

5 years ago
I have no idea if this is still a problem, I don't seem to get extension autoupdates at startup other than when Firefox updates itself now.  Maybe it's just my profile getting old, as I have automatic update of extensions enabled. Firefox updates are disabled, don't know if that would matter.

I'll leave it to someone else to decide if this is still a problem, as I haven't noticed anything for years now. As far as I'm concerned, there's no problem anymore.

Comment 11

5 years ago
(In reply to torhu from comment #10)
> I'll leave it to someone else to decide if this is still a problem, as I
> haven't noticed anything for years now. As far as I'm concerned, there's no
> problem anymore.

Thanks. WFM based on feedback.
Status: NEW → RESOLVED
Last Resolved: 11 years ago5 years ago
Flags: needinfo?(torhu)
Flags: needinfo?(bolsh)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.