Status

()

Firefox
Preferences
--
major
RESOLVED DUPLICATE of bug 361098
11 years ago
11 years ago

People

(Reporter: Smoky Stover, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I confirmed this bug by going to http://www.alltheweb.com and copied Chinese characters into the search area.  The result was to show the raw unicode codes rather than the Chinese characters.  I then ran the same test using IE 6, and the site worked fine. 

This looks like a problem that may be on the Blocker level as it may men that the internal browser code is broken.  The other issue is practicality - - - that means that FF 2 does not work and IE 6 does(XP  Platform) on a side-by-side comparison.  So FF my be great for surfers but not professional deployment; as it may not have the built-in flexibility to deal with the real world.  


Reproducible: Always

Steps to Reproduce:
1. go to http://www.alltheweb.com 
2. Enter Chinese Characters
3. get back un-rendered unicode

Actual Results:  
Un-rendered unicode results

Expected Results:  
If one does the same with IE6 the unicode is rendereed properly into Chinese characters

We spoke with yahoo people, and they indicated that they were aware of the problem and it is an FF problem.  They claim that others browsers work fine.  Also, on looking at the other posts it appears that there might be a general unicode problem where something is broken inside.

We don't want an image that FF is good for surfers but not ready for prime time.

The side-by-side with IE is the problem.

Hope this helps

Comment 1

11 years ago

*** This bug has been marked as a duplicate of 361098 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.