deleting the first message in a thread causes the thread to collapse

VERIFIED DUPLICATE of bug 19412

Status

defect
P2
normal
VERIFIED DUPLICATE of bug 19412
19 years ago
15 years ago

People

(Reporter: blizzard, Assigned: sspitzer)

Tracking

({perf})

Trunk
mozilla0.8
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

If you are reading a thread and it is open and you delete the first message in
the thread the entire thread collapses.  The desired behaviour should be that
the thread should stay open if it started as open.

Updated

19 years ago
Assignee: selmer → putterman
QA Contact: lchiang → fenella

Comment 1

19 years ago
reassign

Comment 2

19 years ago
I see that happens too in the following builds.
Linux (2000-04-18-08 M16)
Win32 (2000-04-18-09 M16)
Mac (2000-04-18-08 M16)
Confirm this bug as NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

19 years ago
Target Milestone: --- → M17

Comment 3

19 years ago
moving to M18 and nominating for beta3
Keywords: nsbeta3
Target Milestone: M17 → M18

Comment 4

19 years ago
This drives me crazy. I'm going to look at it. It's also a major performance
problem (for threaded view users, anyway) because it causes a lot of extra stuff
to happen.
Assignee: putterman → bienvenu

Comment 5

19 years ago
accepting
Status: NEW → ASSIGNED

Updated

19 years ago
Keywords: correctness, perf

Comment 6

19 years ago
On the other hand, if the thread is collapsed and you delete the first message,
the thread expands, and then collapses. Sometimes, the resulting collapsed
thread has no twisty by it so you can't expand it.

Comment 7

19 years ago
Scott and I figured out why the thread expands - it's a bug in our code that
finds the next message to load and thinks it's doing a navigation. Fixing it is
hard, however, because the code works with dom nodes, and unless you expand the
thread, we can't find the next message to load.

Comment 8

19 years ago
Could you add a back-door method in the message folder or something that says, 
"get me the next thread child"?

Comment 9

19 years ago
Or, equally skanky, just use the "raw" RDF APIs to grovel the next kid?

Comment 10

19 years ago
we could add a method to find out the next message to load in the thread from
the DB, as long as messages within threads aren't sorted by rdf - I heard that
they were at one point (e.g., all second level headers are sorted by whatever
the current sort is - is that true, Scott?).

Anyway, the problem I was describing about having to expand the thread was just
because that's the way the mailnews js code works - it could be changed to deal
with URI's instead of dom nodes. Once the dust has settled, and the message has
been promoted to the top level, and is in the dom, we can find it by URI (right,
Scott?)

Comment 11

19 years ago
If the folder is closed, nobody will know that you pulled up "the wrong 
message" ;-)

Comment 12

19 years ago
we do use the raw rdf interfaces to get the next kid in this case.  The problem 
is that when written the function returned a dom node and the only way to get a 
dom node was to expand the tree.  Expanding the tree worked in every case I 
tested  when I wrote the code, but I never tested this case and hence the bug.

I'll just change this to return a uri instead of a dom node and let the calling 
code do the correct thing.

Comment 13

19 years ago
reassign to Scott, since this will require a bit of work.
Assignee: bienvenu → putterman
Status: ASSIGNED → NEW

Updated

19 years ago
Keywords: mail2

Comment 14

19 years ago
Mail triage marking [nsbeta3+] reassigning to dimator.
Assignee: putterman → dimator
Whiteboard: [nsbeta3+]

Comment 15

19 years ago
second pass: - per mail triage
Whiteboard: [nsbeta3+] → [nsbeta3-][cut 8/28]

Comment 16

19 years ago
Dimi Shahbaz's email address is invalid. reassigning to default component owner.
Assignee: dimator → putterman
QA Contact: fenella → esther

Comment 17

19 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2

Comment 18

19 years ago
reassinging to sspitzer
Assignee: putterman → sspitzer
Keywords: mail3
QA Contact: esther → stephend

Comment 19

19 years ago
moving to mozilla0.8. marking nsbeta1+
Keywords: nsbeta3nsbeta1
Priority: P3 → P2
Whiteboard: [nsbeta3-][cut 8/28] → [nsbeta1+]
Target Milestone: M18 → mozilla0.8

*** This bug has been marked as a duplicate of 19412 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
VERIFIED DUP of 19412
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.