RFE: order of members in a mailing list

VERIFIED DUPLICATE of bug 32302

Status

P4
enhancement
VERIFIED DUPLICATE of bug 32302
20 years ago
14 years ago

People

(Reporter: dchaffin, Assigned: chuang)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #343713
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=343713
Imported into Bugzilla on 03/10/99 18:56)

Created by Jason Blue (jblue@mitre.org) on Monday, February 15, 1999 2:18:06 PM
PST
Additional Details :
When creating a new list in an address book,
Netscape ignores the order the list members were
added, and instead seems to use a random order.

Unfortunatelly, at times the order is critical;
for example, when sending mail to Senators and
their aides, politics dictates that the Senator
email addresses appear prior to the aides.

Please enter defect so that Netscape maintains, when
creating or modifying lists, the order specified
for the list members.

From: "Jason D. Blue" <jblue@mitre.org>
Thu 3:13 PM
Subject:Re: Case 99183 & 99173
To: smcarthur@netscape.com
Stuart,
FIRST, Regarding 99183: I believe I found the cause (or at least one of them).
Try the following:
1.Create a new address book under 4.5.
2.Create five new cards in this address book, for example:
a.a new card with a display name of "McArthur,Stuart" (without quotes).
b.Create another new card, this one with a display name of "Jason D. Blue".
c.Create new card for "John Public".
d.Create a new card for "Jamie Private"
e.Create the last new card, for "John Blanco Losada".
3.Create a new list.
4.Drag to the list the above cards, one at a time, in the following specific
order:
e (John Blanco Losada)
a (Jason D. Blue)
c (John Public)
b (McArthur,Stuart)
d (Jamie Private)
5.Click OK to save the list.
6.Open the list, you will now find the list is NOT in the order the cards
where dragged to the list. In fact, they are instead in the order the cards
were
added to the address book itself (a, b, c, d, e).

Please enter a defect report.

Comment 1

20 years ago
This was reproduced locally.
When you go and add a list of users it places them in the order you put them in
the list but when you send the list it then puts them in the order in which
they
were entered in the addressbook.
2/24 dchaffin - have searched database and not found this defect in 4.5 so am
putting in a new defect on this problem.

Comment 2

20 years ago
mass-setting TFV to 4.6 (may be changed or RESOLVED after a more detailed triage
or evaluation)

Comment 3

20 years ago
RFE's will not be considered in the 4.x release.  Adding lchiang to Cc for
consideration into 5.0.

Updated

20 years ago
Assignee: rvelasco → phil
QA Contact: 4114

Comment 4

20 years ago
Is this RFE possible to do?  Reassign to phil.  Pls reassign as needed.  (I
tried to reassign to davidmc@netscape.com, but it's not a valid name.

Updated

20 years ago
Assignee: phil → chuang
Target Milestone: M7

Comment 5

20 years ago
Sounds like an RDF sorting issue. Reassigning to chuang for M7 since that's when
the backend for mailing lists is supposed to be done (according to
http://www.mozilla.org/mailnews/milestones.html)
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Target Milestone: M7 → M8
(Assignee)

Comment 6

20 years ago
Move to M8
(Assignee)

Updated

20 years ago
Target Milestone: M8 → M9
(Assignee)

Updated

20 years ago
Target Milestone: M9 → M11
(Assignee)

Comment 7

20 years ago
mailing list is post beta, move to M11.

Comment 8

20 years ago
This does not need to be fixed in PR1
(Assignee)

Updated

20 years ago
Target Milestone: M11 → M14
(Assignee)

Comment 9

20 years ago
Move to Post Beta M14

Updated

19 years ago
Target Milestone: M14 → M15

Comment 10

19 years ago
Since this bug is marked P4, moving to M17.  If you disagree, please let me know.
Target Milestone: M15 → M17

Comment 11

19 years ago
Not critical for this release.  M20.
Target Milestone: M17 → M20

Comment 12

19 years ago
This is a duplicate of another bug assigned to chuang about sorting items in a 
mailing list, I believe.
Target Milestone: M20 → Future
(Assignee)

Comment 13

19 years ago

*** This bug has been marked as a duplicate of 32302 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 14

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.