All add-ons i download for firefox 2.0 refuse to work.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: jason.moor, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

I have recently installed firefox release 2.0 and have added a few add-ons that i use often. They are all compatible with firefox 2.0 so that is not the problem. When i open the window that manages all these add-ons and allows me to enable or disable them, next to every single add-on there is a notice saying that they have been turned off for my protection. ALL OF THEM! The problem is that when i click on the enable button nothing happens. It refuses to enable them and doesn't allow me to use any of them. I tried desabling any program that might be causing this like antivirus and the works and still they were all disabled. This is really frustrating as it turns firefox into yet another boring explorer without any extra features.

Please help me.

Reproducible: Always

Steps to Reproduce:
1.install firefox add-ons such as Adblock Plus 0.7.2.2 or Download Statusbar 0.9.4.5
2.Restart firefox and go to tools
3.Open the add ons window
4.Click on any add on and the last line of text reads: Disabled for your protection
5.Click enable

Actual Results:  
Absolutely nothing happens. No message that it is enabled, or that it will be once you restart firefox. It simply keeps the message that it is disabled for my protection.

Expected Results:  
The add ons are enabled and next time i restart firefox they are ready to use.

Updated

12 years ago
Component: General → Extension/Theme Manager
QA Contact: general → extension.manager
Version: unspecified → 2.0 Branch
Are you using the default theme? If not, try switching to it and report back.

Comment 2

12 years ago
I've got a similar pproblem, i cannot uninstall or use any extensions, let alone install any new ones.

I have tried uninstalling and reinstalling firefox completely, removing left over system files and still with no luck!

Brad

Comment 3

12 years ago
After updating to Firefox 2.0 I added several new themes.  I go to "tools", then "add-ons", find the theme I want to use.. then press USE THEME.  I close the window, and.. nothing happens.  The theme does not change. I've tried to apply other themes with no luck.  The theme will not change.  What can I do?
(In reply to comment #3)
> After updating to Firefox 2.0 I added several new themes.  I go to "tools",
> then "add-ons", find the theme I want to use.. then press USE THEME.  I close
> the window, and.. nothing happens.  The theme does not change. I've tried to
> apply other themes with no luck.  The theme will not change.  What can I do?
Did you restart the application or just close the add-ons mgr?

Comment 5

12 years ago
After I selected USE THEME I closed the box and re-started the pc.  There was no difference.  I tried it at least 3 times choosing different themes each time.  Still no use.  Before I updated to Firefox 2.0 I had no problem in changing the theme.

Comment 6

12 years ago
I found the solution!  When I re-started the pc it closed all the tabs in that Firefox session.  When re-opening Firefox I clicked on "restore last session" so I would get all the tabs back that I was previously viewing, instead of clicking "start new session".  Next time I re-started I clicked on "start new session" and the new theme appeared!  Everything is fine now.  Thank you everyone for your comments. 
Note: this appears to be a side affect to the app not handling the shutdown message properly from the OS.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.