Request: Allow personality to be set when sending, depending on email address sent to

RESOLVED DUPLICATE of bug 359236

Status

Penelope
General
P5
enhancement
RESOLVED DUPLICATE of bug 359236
12 years ago
9 years ago

People

(Reporter: Roberta Millstein, Assigned: Matt Dudziak)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

There should be a way to associate email addresses with particular 
personalities, so that when email is sent to person X, the personality 
(and the associated "From:", signature, etc.) is set to personality Y.  

Reproducible: Always

Comment 1

12 years ago
Add stationery to the list of things to be associated with the personality
(Assignee)

Comment 2

12 years ago
This should probably be filed under 'Filtering' but I will leave it like this for now.

Curiously, what happens if you are sending to 'X' and 'Y', and your rules say to use Personality 'A' when sending to person 'X' and to use Personality 'B' when sending to person 'Y'? 

Should Penelope use Personality 'A' as person 'X' appeared first in the TO field?
Should Penelope send 2 separate messages? (ouch if the message is large and you are sending a large attachment over a slow connection)

Please feel free to elaborate on how this should be implemented....
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)

> Curiously, what happens if you are sending to 'X' and 'Y', and your rules say
> to use Personality 'A' when sending to person 'X' and to use Personality 'B'
> when sending to person 'Y'? 
> 
> Should Penelope use Personality 'A' as person 'X' appeared first in the TO
> field?
> Should Penelope send 2 separate messages? (ouch if the message is large and 
> you are sending a large attachment over a slow connection)

Good question!  I hadn't thought of that situation.

My first instinct was to say that the "Eudora Way" (now, the "Penelope Way") is to provide both options, and let the user choose.

However, on reflection, the first option (using Personality 'A') seems a bit arbitrary and kludgy to me.  Also, since the whole idea behind my suggestion is to avoid sending email with the "wrong" personality, it might be better to pop up a warning that says something like, "This message will be sent N times, from different personalities.  Do you wish to proceed?"  I think in most cases, the response will be "cancel"; the user has probably made a mistake by including these different personality-recipients on the same To: line.

On the other hand, I am willing to be persuaded that the Eudora/Penelope Way is a better solution.
(Assignee)

Updated

12 years ago
OS: Mac OS X 10.3 → All
Hardware: Macintosh → All

Comment 4

12 years ago
This is a problem that could do with a nice solution.

For the multiple personality case a dialog offering "send n times", "cancel" and "use personality: <popup>" would seem to address the problem.

In most cases I think this would be used ot make sure new messages to individuals go from the right mail address and with the right signature etc. I'd probably actually be happy to have a "query if to X and not from Y" setting, no need to actually change anything automatically just a way to trigger an overridable send block. Doesn't some mailer offer this already?

Comment 5

12 years ago
This is not a current Eudora feature.  Sounds like a nice to have, but I won't vote for it because it doesn't need to be in v1.0.  I want to see existing Eudora features implemented in Penelope. 

Does this feature request make any sense if applied directly to Thunderbird?  

In any case, I think it would best be implemented as an attribute of the address book entries.  Then you could avoid scarring Mom with your sexstarved@whereever personality when you double click on her address entry ;).  
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> This is not a current Eudora feature.  Sounds like a nice to have, but I won't
> vote for it because it doesn't need to be in v1.0.  I want to see existing
> Eudora features implemented in Penelope. 

I had thought that we were supposed to vote for features we wanted, not necessarily ones we wanted *now*.  I would assume that most enhancements would be lower priority, by definition.  That being said, this is something that I have wanted for a long time.  It always frustrated me that Eudora never did it; it seemed like such a logical extension of multiple personalities.  So, I am hopeful that it gets implemented in Penelope.
 
> Does this feature request make any sense if applied directly to Thunderbird?  

I assume that someone would have corrected me if it didn't.
 
> In any case, I think it would best be implemented as an attribute of the
> address book entries.  

Either that, or it's part of the filters.  I think I'd orginally thought of it as part of the filters, because it's what filters do now, except for incoming mail only.  

It occurs to me that there are other things besides personalities that one might wish to associate with particular people - for example, attachment settings (if you know that someone can only receive attachments from you when the settings are a certain way) or styles/no styles/both, depending on the known preferences of the recipient. I guess this is the spirit of the suggestion about stationery above.

> Then you could avoid scarring Mom with your
> sexstarved@whereever personality when you double click on her address entry ;). 

*ahem*  No comment.  :)

But yes, that's the general idea. Although would want it to work regardless of how the address was entered; I tend to be a nickname-auto-completion person myself (see bug #361324).  

(Reporter)

Comment 7

12 years ago
(In reply to comment #4)
> This is a problem that could do with a nice solution.
> 
> For the multiple personality case a dialog offering "send n times", "cancel"
> and "use personality: <popup>" would seem to address the problem.

That is a nice solution. 
 
> In most cases I think this would be used ot make sure new messages to
> individuals go from the right mail address and with the right signature etc.
> I'd probably actually be happy to have a "query if to X and not from Y"
> setting, no need to actually change anything automatically just a way to
> trigger an overridable send block. Doesn't some mailer offer this already?

That would help, but I'd prefer the automatic.  Although I can see where there might be times when an override would be useful... say, if I usually don't email person X from my work email, but it's the only one that is working at the moment.

(Assignee)

Comment 8

12 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > This is not a current Eudora feature.  Sounds like a nice to have, but I won't
> > vote for it because it doesn't need to be in v1.0.  I want to see existing
> > Eudora features implemented in Penelope. 
> 
> I had thought that we were supposed to vote for features we wanted, not
> necessarily ones we wanted *now*.  I would assume that most enhancements would
> be lower priority, by definition.  That being said, this is something that I
> have wanted for a long time.  It always frustrated me that Eudora never did it;

YES. You should vote for features you want, regardless of whether or not the feature is in the current Eudora.



(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 9

11 years ago
(In reply to comment #5)
> This is not a current Eudora feature.  Sounds like a nice to have, but I won't
> vote for it because it doesn't need to be in v1.0.  I want to see existing
> Eudora features implemented in Penelope. 
> 

I agree. the only oprion I wanted was to be able to send plain text or html text to different recipients in the same msg. Outlook offers this. I need this as some stupid Lotus notes users (old version) cannot even see any html msgs from eudora

Comment 10

11 years ago
(In reply to comment #9)
> (In reply to comment #5)
> > This is not a current Eudora feature.  Sounds like a nice to have, but I won't
> > vote for it because it doesn't need to be in v1.0.  I want to see existing
> > Eudora features implemented in Penelope. 
> > 
> I agree. the only oprion I wanted was to be able to send plain text or html
> text to different recipients in the same msg. Outlook offers this. I need this
> as some stupid Lotus notes users (old version) cannot even see any html msgs
> from eudora

This feature is important to me and I tried to use the Eudora outbound mail filter to set personality but could never get it to work. Several emails to the Eudora support folk on this topic got black-holed.

My need is similar to the comments above but a little different - I have two "home" email personalities/addresses (one for family, one for other), one "day job" personality (so I can check my work email from home), a "consulting" email address (for side work), and I have an amateur radio personality where the From: address  has my amateur radio callsign appended to my name. I use this for amateur radio related email and on several amateur radio mailing lists.

Like most people I use Eudora filters to auto-sort the incoming mail into folders by source - the amateur radio mailing lists feed into separate mailboxes under a "Mailing Lists" folder.

I'd use the feature mentioned to force the personality to the "consulting" personality when communicating with clients, and to the amateur radio personality when sending to the amateur radio mailing lists.

So I vote for this bug and hope it makes it into an early release... or at least the outbound filter code gets fixed.
(Assignee)

Updated

10 years ago
Priority: -- → P5
(Assignee)

Comment 11

9 years ago
I am goung to mark this a duplicate of Bug #359236 as it would be a before-send filter that would do this.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 359236
You need to log in before you can comment on or make changes to this bug.