Crashes when visiting this website (just before the rendering)

RESOLVED DUPLICATE of bug 304370

Status

()

Firefox
Shell Integration
--
critical
RESOLVED DUPLICATE of bug 304370
12 years ago
4 years ago

People

(Reporter: S Egbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; i686) KHTML/3.5.2 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

It works for Firefox 1.5 and 2.0, Windows-platform
It works for Konqueror on Linux
It works for Lynx (console-based web-browser)

But on my Gentoo Linux, Firefox 1.5 and 2.0 crashes when I enter in the URL 'http://www.autocad.com/'

So, I reran it again using debug mode:

$ firefox -safe-mode --debug --sync
              MOZILLA_FIVE_HOME=/usr/lib/mozilla-firefox
                LD_LIBRARY_PATH=/usr/lib/mozilla-firefox:/usr/lib/mozilla-firefox/plugins
                        DISPLAY=:0.0
                       debugger=gdb

GNU gdb 6.4
Copyright 2005 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) b gdk_x_error
Function "gdk_x_error" not defined.
Make breakpoint pending on future shared library load? (y or [n]) y

Breakpoint 1 (gdk_x_error) pending.
(gdb) run
Starting program: /usr/lib/mozilla-firefox/firefox-bin -safe-mode --sync
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1220966736 (LWP 10057)]
[New Thread -1238459488 (LWP 10063)]
[New Thread -1246852192 (LWP 10064)]
[New Thread -1260627040 (LWP 10065)]
[New Thread -1269285984 (LWP 10066)]
[New Thread -1278526560 (LWP 10067)]
[New Thread -1286919264 (LWP 10068)]
[New Thread -1295311968 (LWP 10070)]
[New Thread -1303704672 (LWP 10071)]
[Thread -1303704672 (LWP 10071) exited]
[New Thread -1312097376 (LWP 10072)]
[Thread -1312097376 (LWP 10072) exited]
[New Thread -1312097376 (LWP 10073)]
[New Thread -1303704672 (LWP 10074)]
[Thread -1312097376 (LWP 10073) exited]
[New Thread -1312097376 (LWP 10075)]
[New Thread -1312097376 (LWP 10075)]
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 102 error_code 8 request_code 146 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Program exited with code 01.
(gdb) bt
No stack.


Tried it with gdb 'handle SIG33 nostop noprint'
Tried it with b gdk_x_error, but got X BadMatch error (in fact, I got three of them)

Reproducible: Always

Steps to Reproduce:
1. Enter in 'http://www.autocad.com/
2.
3.

Actual Results:  
Crash.

When entered in from the BASH shell prompt, it runs but upon entering in the 'autocad.com' website, it just returns back to shell prompt

No traceback information were given in run-mode nor debug-mode.

Expected Results:  
Render the page, or at least show me a traceback.

This also occurs in Firefox 2.0 as well

Comment 1

12 years ago
the problem is flash.

to set the breakpoint, you probably need symbols for gdk.
Whiteboard: DUPEME

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 304370 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.