Performance regression with this testcase, which continuously reloads a page

RESOLVED FIXED

Status

()

Core
Graphics
P4
normal
RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: vlad)

Tracking

({perf, regression, testcase})

Trunk
x86
Windows XP
perf, regression, testcase
Points:
---
Bug Flags:
blocking1.9.1 -
wanted1.9.1 +
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
I was hoping that I could find a possible regression in performance for bug 360789, but I didn't see that.
But I see with the testcase that I made a performance regression when cairo was turned on on windows.
So that's why I'm filing this bug. It might not be the most useful testcase, but it's probably useful to keep track of it, to ensure that the performance will turn back into pre-cairo days.
(Reporter)

Comment 1

11 years ago
Created attachment 246144 [details]
testcase

You need to download the testcase locally to get a good working testcase.
In the statusbar, I get the following results:
2006-02-22 build: 17391ms 
2006-02-25 build: 23735ms 
That is the period when cairo was turned on in windows.

2006-11-20 build: 21000ms
2006-11-20 branch build: 19484ms
Not as noticeable a difference, but still. (It's better to test with a non-cairo trunk build).
(Reporter)

Updated

11 years ago
Blocks: 334719
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
(Reporter)

Comment 2

9 years ago
Current trunk gives 28577ms
A branch build gives 24510ms
So there is still a performance regression visible here.
Note that trunk doesn't show the iframe big anymore (because of some CSS rule), so that should be a reason to be even quicker than branch, perhaps.
Flags: wanted1.9.1?
Flags: blocking1.9.1?
I don't think this would block 1.9.1.  Please re-nom if you disagree.
Flags: blocking1.9.1? → blocking1.9.1-
There's a border involved here, so that's almost certinly it; could get faster with an upcoming patch to borders.
Assignee: nobody → vladimir
Flags: wanted1.9.1? → wanted1.9.1+
Priority: -- → P4
Yeah; Fx 3: 24322 with border patch: 23020.  Will land that when the tree reopens.
I think vlad landed it, though borders have continued to plague is well into the year 2010!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.