Add and activate new sorting routine for URIs in password manager (and elsewhere)

RESOLVED DUPLICATE of bug 143472

Status

SeaMonkey
Passwords & Permissions
--
enhancement
RESOLVED DUPLICATE of bug 143472
11 years ago
10 years ago

People

(Reporter: Ulrich Windl, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20060911 SUSE/1.0.6-0.1 SeaMonkey/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20060911 SUSE/1.0.6-0.1 SeaMonkey/1.0.6

The Password manager cannot sort the displayed items by URI. Sorting by URI would be desired.
A sorting routine for URIs would probably have to work backwards, maybe similar like the following Perl pseudo-code:

join('', reverse split(/\./, $a)) cmp join('', reverse split(/\./, $b))

That is first consider top-level domains, then sub-domains...

Conidering the amount of URIs accumulating in the password manager, a tree view where initially everything but the top-level domains are collapsed would be quite helpful as well.

Reproducible: Always

Steps to Reproduce:
Open Password Manager and see what we have now
Actual Results:  
A poor solution

Expected Results:  
A better solution

See details.
(Reporter)

Comment 1

11 years ago
Created attachment 246270 [details]
Sample screen-shot showing the problem

You'll see that sorting from the front (like "http" or "www") is not optimal.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 143472
You need to log in before you can comment on or make changes to this bug.