[Cairo] Help viewer is broken

RESOLVED FIXED

Status

SeaMonkey
Help Viewer
--
major
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: Hiro, Assigned: Jeff Walden (gone starting June 8))

Tracking

Trunk
PowerPC
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
In following build and tinderbox build(bug323934), Help Viewer doesn't correctly display help. 
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/experimental/cairo-cocoa/latest-trunk/

In Cocoa Firefox, there is no problem. 

Reproducible: Always

See screen shot.

Mac OS X 10.3.9
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061109 
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061122 Minefield/3.0a1
(Reporter)

Comment 1

12 years ago
Created attachment 246273 [details]
screen shot
(Reporter)

Updated

12 years ago
Summary: [Cairo] Help view is broken → [Cairo] Help viewer is broken

Comment 2

12 years ago
SeaMonkey Help viewer is broken as well.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
Blocks: 323934

Comment 3

12 years ago
i don't see that in my builds, but i do see some tree issues

Comment 4

12 years ago
This is weird, but it looks like content in Help window (xhtml) is flowing up-->down instead of left-->right.

Comment 5

12 years ago
The reason for this is that ex units seems to be broken on (at least) 10.3.9 (the Help viewer uses 'max-width: 120ex;' for body). I was looking at one of the help xhtml files in DOMi and the body width is always 0 when you have 'max-width: 120ex;' I'm going to file a new bug for the ex issue and make this one depend on the new bug.
No longer blocks: 323934

Updated

12 years ago
Depends on: 364058

Comment 6

12 years ago
Was this fixed by bug 364058?

Comment 7

12 years ago
(In reply to comment #6)
> Was this fixed by bug 364058?
> 
Yes.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Toolkit → Seamonkey
You need to log in before you can comment on or make changes to this bug.