[Cairo / Cocoa] All borders not at pixel boundaries are a pixel too thick

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Håkan Waara, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
PowerPC
Mac OS X
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
After the switch to cairo, the inset on form controls' borders are extremely thick.

Screenshots coming up.
(Reporter)

Comment 1

11 years ago
Created attachment 246281 [details]
Before 

Before the cairo-switch.
(Reporter)

Comment 2

11 years ago
Created attachment 246283 [details]
After

Note that all form controls (buttons, textfields, select menus) have almost doubled their border's thickness.
Attachment #246283 - Attachment is patch: false
Attachment #246283 - Attachment mime type: text/plain → image/png

Comment 3

11 years ago
Radio buttons look better, though.  http://quotes.burntelectrons.org/1594

Comment 4

11 years ago
What date was the switch to Cairo? I'm having trouble finding out on Bonsai or Bugzilla.

Comment 5

11 years ago
(In reply to comment #4)
> What date was the switch to Cairo? I'm having trouble finding out on Bonsai or
> Bugzilla.

Sorry, never mind. I don't know how I missed bug 323934, checked in 2006-11-21 16:58.

Blocks: 334729
Flags: blocking1.9?
*** Bug 363686 has been marked as a duplicate of this bug. ***
Flags: blocking1.9? → blocking1.9+
What's going on here seems like a cairo bug.  Any border that's not aligned to a pixel boundary is getting drawn a pixel too thick.  It's nothing specific to form controls.  I'll attach a testcase to show this.

(It's probably showing up more reliably for vertical borders presumably because vertical coordinates are much more cumulative, and therefore much less likely to be pixel-aligned.)
Summary: [Cairo / Cocoa] Form borders are too thick (even thicker than before) → [Cairo / Cocoa] All borders not at pixel boundaries are a pixel too thick
Created attachment 255997 [details]
testcase (all borders should be 2px wide)

All the borders in this testcase should be 2px wide, but only 1 out of every 10 is; the rest (not aligned to pixel boundaries) are 3px wide.

Comment 9

11 years ago
It this bug also responsible for making some link underlines appear too close to the link text?  Or is that a separate bug?
Separate.  Underlines aren't done using FillPolygon, and I think the cause of this bug is a rounding bug in FillPolygon.
see bug 365336 for the underline problem.
Blocks: 289480
This should be fixed by the patch for bug 368247.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 368247
Resolution: --- → FIXED

Updated

11 years ago
Duplicate of this bug: 317273

Updated

11 years ago
Duplicate of this bug: 317273
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.