unable to log into https://intranet.mozilla.org with trunk builds

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: moco, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

[cocoa][cairo] unable to log into https://intranet.mozilla.org with trunk mac builds

I tested a basic http auth site (http://prism.library.cornell.edu/control/authBasic/) and it worked fine.

josh, are you able to log in if you use a firefox trunk build?
actually, this may not be a cocoa cairo issue at all, but that's what I am using.
I am able to reproduce this with trunk windows, too!

more information:

I was able to log into intranet.mozilla.com with 2006103004 Minefield 3.0a1.  when I went to log in, the auth prompt was filled in with my saved password and username.

but, when I updated my minefield build to 2006112204 Minefield 3.0a1, the auth prompt was blank, and when I attempt to log in with my user and pass, it is not accepted and I get a 401 Authorization Required error from the server:

Authorization Required

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.
Apache/2.0.52 (Red Hat) Server at intranet.mozilla.org Port 80

so the regression is cross platform, and happened after 10/30/06

vlad, bad enough to block 1.9a1?


Flags: blocking-firefox3?
Keywords: regression
OS: Mac OS X 10.4 → All
Summary: [cocoa][cairo] unable to log into https://intranet.mozilla.org with trunk mac builds → unable to log into https://intranet.mozilla.org with trunk builds
This might be caused by bug 359824.
> This might be caused by bug 359824.

gavin is right.  when I backed out the cause of bug #359824, this now works, including the problem where my user/pass was not autofilled.

Depends on: 359824
fixed by backing out the patch in bug #359824.

thanks to waldo and gavin.

ryan, if you come up with a new patch for #359824, I can test against intranet.mozilla.org (if you need me to)
No longer blocks: 223846
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: blocking-firefox3?
Resolution: --- → FIXED
Depends on: 223846
Do we know _why_ the patch for bug 223846 caused problems here?
Blocks: 223846
No longer depends on: 223846
Ah, nevermind.  We do.  Bug 359824 describes it.
You need to log in before you can comment on or make changes to this bug.