left-aligned text in cells gets centered instead

VERIFIED FIXED

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: R.K.Aa., Assigned: karnaze (gone))

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build ID 2000041716 M16
Seems all text that should be right-aligned in cells at above URL gets centered
instead.
(Reporter)

Comment 1

18 years ago
LEFT aligned...dang..
Summary: right-aligned text in cells gets centered instead → left-aligned text in cells gets centered instead
(Reporter)

Comment 2

18 years ago
hmm looked at the source: the text isn't explicitly left-aligned but all other
browsers displays it as left-aligned. There's a <DIV ALIGN="justify"> there -
perhaps a clue.

Comment 3

18 years ago
rickg checked in some stuff for DTD recognition.  Looks like this broke
something here: the doctype of this page is HTML 4.0 Transitional, but
apparently it gets parsed in standard mose (where <CENTER> menas text-align:
center, which inherits into the TABLE cells).  Confirming, and reassigning.
Assignee: karnaze → rickg
Status: UNCONFIRMED → NEW
Component: HTMLTables → Parser
Ever confirmed: true
Keywords: regression
QA Contact: chrisd → janc

Comment 4

18 years ago
This isn't a parser bug. In the new world, the transitional DTD (without 
strict.dtd URI) is handled as a standard-mode document, meaning we throw out nav 
quirks. Removing the doctype (or using a doctype the enables quirks) is your 
anwser.

I'm forwarding the layout but to karnaze.
Assignee: rickg → karnaze

Comment 5

18 years ago
Which doctypes now trigger quirks mode? loose.dtd doesn't seem to.
(Reporter)

Comment 6

18 years ago
well hooray - with build ID 2000-041908 it's business as usual - no unexpected
centered text on freshmeat.net. But is this a fix or a mishap?

Comment 7

18 years ago
After some discussion in n.p.m.layout, transitional dtd gets processed in quirks
mode again.  So I'll mark this, hm, FIXED.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
This was fixed in the next build, ages ago, and page still looks OK.
Verifying. 2000-072113
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.