Please map Ctrl+K to a search dialog

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WONTFIX
12 years ago
6 years ago

People

(Reporter: Jason Spiro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME INVA/WONT?])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061122 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061122 SeaMonkey/1.5a

It would be great if Ctrl+K opened a search dialog box similar to that shown in https://bugzilla.mozilla.org/attachment.cgi?id=179437 (attachment 179437 [details] to Firefox bug 235204)

I am not the only one who would like this feature. It has also been requested in a NewsForge review of SeaMonkey at: http://software.newsforge.com/article.pl?sid=06/08/08/1444211&tid=130&tid=138

Reproducible: Always
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041201 SeaMonkey/2.0a1pre

On SeaMonkey, the URL bar (Ctrl-L) does double duty as a search bar. There is even a Search button which can be enabled from a checkbox near the bottom of the "Browser" preferences. If you want to select a different search engine than the current default, open the sidebar (F9). I expect this RFE will be WONTFIXed.
Version: unspecified → Trunk
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101210 Firefox/4.0b8pre SeaMonkey/2.1b2pre - Build ID: 20101210025813

In addition to what I mentioned more than 2½ years ago in comment #1, Ctrl+F opens a "proper" search dialog.

I suggest WONTFIX or even INVALID.
Whiteboard: [CLOSEME INVA/WONT?]
Oh, and the Search button is now on the button palette, not in the prefs dialog anymore.

Comment 5

8 years ago
As far as I know KaiRo would like the Ctrl+K key to access the search bar, as and when that gets ported to SeaMonkey.

Comment 6

8 years ago
Although doesn't it already focus the search sidebar if that's open?
(Reporter)

Comment 7

8 years ago
Basically I wanted Ctrl+K to open a simple dialog box that let me do a Google search.  This would make the key sequence Ctrl+K foo <Enter> do a Google search for information about foo, just as the same key sequence would do in Firefox.  I don't like sidebars, so I don't use the search sidebar.

I no longer use SeaMonkey so I no longer want this.  But I suggest you leave this bug open.  This is because someone else also wanted it, in http://software.newsforge.com/article.pl?sid=06/08/08/1444211&tid=130&tid=138 (a page which no longer exists).
(In reply to comment #5)
> As far as I know KaiRo would like the Ctrl+K key to access the search bar,
> as and when that gets ported to SeaMonkey.

+1 (FTR it is available now, but not displayed by default.)

(In reply to comment #6)
> Although doesn't it already focus the search sidebar if that's open?

Maybe it did, but with SM 2.1 it (currently) doesn't so there's no clash.

Enough Council members are CC'd here, please take a decision (either confirm what KaiRo and I suggest, suggest alternatives, or close).

Comment 9

7 years ago
I don't have a strong preference on this. Punt to the rest of you guys.

Comment 10

7 years ago
Focis in search bar if it present.
If not - open sidebar with search, and focus in search field there.

Comment 11

6 years ago
(In reply to Jason Spiro from comment #7)
> Basically I wanted Ctrl+K to open a simple dialog box that let me do a
> Google search.  This would make the key sequence Ctrl+K foo <Enter> do a
> Google search for information about foo, just as the same key sequence would
> do in Firefox.  I don't like sidebars, so I don't use the search sidebar.
F6 foo up <Enter> is enough, IMHO, not mentioning about keyword alternative
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.