Closed Bug 361600 Opened 16 years ago Closed 15 years ago

[Cairo] When FindToolbar is displayed(Cmd+F , FAYT, etc.), the screen does the flash

Categories

(Core :: Graphics, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sugar.waffle, Unassigned)

References

Details

When FindToolbar is displayed with Cmd+F and FAYT, the browser screen does the flash. 
In Cocoa Firefox, there is no problem.

Reproducible: Always

Mac OS X 10.3.9
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061122 Minefield/3.0a1
I see the same kind of flashing the first time I open a new tab, and sometimes after switching tabs.
Confirming.

I also see some flickering whenever I click on a link, just before the new pages loads.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I suspect this may have been fixed by the backout of the patch for bug 130078.
(In reply to comment #3)
> I suspect this may have been fixed by the backout of the patch for bug 130078.
> 
On a home made build, started after the backout of bug 130078, the flickering I saw in comment #2 is gone, and what Jesse mentions is gone as well.

There is still a bit of 'jumping' at the moment FAYT is triggered (the moment the find toolbar appears).
10.4.8 PPC


I still see all the white-flashing in the 2006-11-25 nightly.  I think this is a regression from the switch to cairo, not from the view hierarchy change.
Blocks: 323934
Blocks: 334729
Should this bug really be in the Firefox product?  If it should be in Core, please move there and request blocking1.9.
Flags: blocking-firefox3?
Component: Find Toolbar / FastFind → GFX: Thebes
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: fast.find → thebes
Flags: blocking1.9?
*** Bug 363199 has been marked as a duplicate of this bug. ***
Is anyone else also seeing flickering (of the whole page) when scrolling? Should that be filed as a separate bug?
I'm not seeing flickering when I scroll.
(In reply to comment #8)
> Is anyone else also seeing flickering (of the whole page) when scrolling?
> Should that be filed as a separate bug?

Perhaps you're running into bug 324819?
Flags: blocking1.9? → blocking1.9+
This problem doesn't occur. 
FIXED ?

Mac OS X 10.3.9
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a4pre) Gecko/20070411 Minefield/3.0a4pre
Yeah, apparently. This was probably fixed by the last cairo update.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Depends on: 374462
You need to log in before you can comment on or make changes to this bug.