Simplify the overall user interface - integrate "Go", "Stop", "Reload" buttons into single control

RESOLVED DUPLICATE of bug 351248

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 351248
12 years ago
12 years ago

People

(Reporter: rbuszka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

It may be possible to leapfrog IE's simplification of the typical browser interface by integrating the "Go", "Stop", and "Reload" functions into a single button at the end of the URL bar, where the "Go" button is now. When a user types a new address into the bar, the "Go" icon (forward arrow) appears in the button. The user can press the button to begin loading the requested page. While the page is loading, the "Go" icon changes to the "Stop" icon (red X). When the page has loaded, the "Stop" icon changes to the "Reload" icon (cycling arrow). The "Reload" icon remains until the user enters a new unique web site address, and then it changes into the "Go" icon. This way, the "Reload" and "Stop" icons can be eliminated, reducing the visual clutter and simplifying the interface beyond the simplicity offered in the new Windows Internet Explorer. This change would also allow an address bar to be included in pop-up windows, offering the user some amount of control of the page loading. This would be especially useful if the user does not want a pop-up window to continue loading.

Reproducible: Always
This has been suggested, discussed and beaten to death at least three dozen times already in various bugs, newsgroups and IRC. Duping to the only one that's survived.

*** This bug has been marked as a duplicate of 351248 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.