many errors about tabs in javascript console

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: tech, Unassigned)

Tracking

SeaMonkey 1.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.0.8) Gecko/20061030 SeaMonkey/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.0.8) Gecko/20061030 SeaMonkey/1.0.6

The javascript console is permanently filled with errors like :
Erreur : this.mTabListeners[i] has no properties
Fichier source : chrome://global/content/bindings/tabbrowser.xml
Ligne : 769
or 
Erreur : uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.canGoBack]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://navigator/content/nsBrowserStatusHandler.js :: anonymous :: line 306"  data: no]

And it seems that it prevent Seamonkey to show the right url for the right tab

Reproducible: Always

Steps to Reproduce:
1.start seamonkey
2.open javascript console
3.note that js console is filled of errors

Updated

11 years ago
Version: unspecified → 1.8 Branch

Comment 1

11 years ago
looks like bug 331581.  do you have the needlesearch extension installed?
(Reporter)

Comment 2

11 years ago
I don't have needlesearch nor session saver installed

Comment 3

11 years ago
OK, do you see the bug with a clean profile and no extensions?
(Reporter)

Comment 4

11 years ago
When using a clean profile, I get much less errors in JS console only a few :
Erreur : [Exception... "'Error opening input stream (invalid filename?)' when calling method: [nsIModule::getClassObject]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "<unknown>"  data: no]
After a little testing, the synchro problem between tabs and url bar doesn't seems to occur.

If it can help this is the list of the extensions installed in my usual profile which appear in extension manager :
-Adblock plus
-AutoConfig
-Codetch
-Communicator Shared
-Content Pack Switching
-Cookie Manager
-Document Inspector
-Editor
-Extension Manager 2.0
-Extension Uninstaller API 2.0
-Form Manager
-Javascript Debugger
-Linky
-Messenger (Five times !?)
-Mozilla help viewer
-MozLDAP
-Navigator
-Necko
-NoScript 1.1.4.5.061030
-pipnss
-pippki
-Platform for Privacy Preferences Project
-Platform Specific
-Platform Specific Bindings
-Quick Local Switcher
-Reporter.mozilla.org
-Thunderbird Virtual identity Extension
-Toolkit
-US regional Contents
-User Agent Switcher 0.6.8
-Web Developper 1.0.2
-Win-specific dl mgr files
-Windows specific resources
-XBL marquee Emulation
-Ñandù
 

Comment 5

11 years ago
> When using a clean profile, I get much less errors in JS console only a few :

Are any of the extensions installed to the app dir instead of the profile so that the clean profile would still see them?
(Reporter)

Comment 6

11 years ago
At least adblock plus seems to be installed out of the profile, 'cause I can see it when using the new "clean" profile... There are also Dom inspector, dom inspector and javascript debugger which are par of the installation.
Is there a way to control which extension are installed and where, without using
Extension Manager ?
(Reporter)

Comment 7

11 years ago
The bug is confirmed in the last Seamonkey release 1.0.7

Comment 8

10 years ago
To kill adblock, if it's in the app dir, is just delete the directory where it resides, c:\program files\<seamonkey dir>\extensions\<adblock dir>

What do you see in error console after that?
Version: 1.8 Branch → SeaMonkey 1.0 Branch
(Reporter)

Comment 9

10 years ago
(In reply to comment #8)
I don't know since which release this issue disappeared, but with the current one,  it's gone ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 10

10 years ago
thanks for closing, but FIXED is not an appropriate resolution.  See
  https://bugzilla.mozilla.org/page.cgi?id=fields.html#status

let's call it INVALID (rather than WORKSFORME) because the main problem, related to tabbrowser extension, was gone with clean profile in comment 4
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.