Closed Bug 361679 Opened 13 years ago Closed 13 years ago

Webbugs in RSS-Feeds downloaded despite settings on privacy

Categories

(MailNews Core :: Feed Reader, defect)

1.8 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 245361

People

(Reporter: arnimus, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Thunderbird 1.5.0.8

despite the setting "don't load external pictures in messages" they get downloaded when reading individual RSS-messages.

Reproducible: Always

Steps to Reproduce:
1. click on any RSS-message from slashdot
2.
3.

Actual Results:  
webbug gets downlaoded, tcpdump shows connection to 66.150.96.111:80 (previously a redirect from rss.slashdot.org)

Expected Results:  
not downloaded the webbug

i don't know if this is intented or not, but at the moment at least the text of the settings is misleading (considering single RSS-articles also a "message"). solutions might be to either:
1. don't download webbugs 
2. change the settings text to "don't download pictures in emails"
Version: unspecified → 1.5
This is basically the same as bug 262611, no?

I don't think you can reasonably claim that images or other remote items loaded from a page is a "web bug".  The feed is not addressed to any particular user; the page load is not trackable to any particular user; TB doesn't even support cookies.

Are you aware of any other RSS reader that blocks remote images when reading RSS feeds?  

Finally: have you tried subscribing to the feed with "Show article summary instead of loading the web page"?
(In reply to comment #1)
> This is basically the same as bug 262611, no?

hmm, that sounds like it's only about subscribing to the whole page, but it's also happening in the summary, look at the code of http://rss.slashdot.org/Slashdot/slashdot

> I don't think you can reasonably claim that images or other remote items loaded
> from a page is a "web bug".

i would call a 1x1 gif a webbug, the URL is from the RSS-feed above:

$ wget http://rss.slashdot.org/~r/Slashdot/slashdot/~4/53259924
--21:39:33--  http://rss.slashdot.org/~r/Slashdot/slashdot/~4/53259924
           => `53259924.1'
Auflösen des Hostnamen »rss.slashdot.org«.... 66.150.96.117, 66.150.96.111
Verbindungsaufbau zu rss.slashdot.org|66.150.96.117|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 43 [image/gif]

100%[=================================================================================>] 43            --.--K/s

21:39:33 (3.42 MB/s) - »53259924.1« gespeichert [43/43]

a@ubuntu:~$ file 53259924
53259924: GIF image data, version 89a, 1 x 1


>  The feed is not addressed to any particular user;

but some people have a static IP, they should at least be able to choose.

> Finally: have you tried subscribing to the feed with "Show article summary
> instead of loading the web page"?

yep, it's in the summary. 

i'll include this stuff in bug 245361 because it's somehow similar, but that's open for over 2 years. is it possible give it a higher priority because this webbug thing is probably not expected (opposed to avoiding the ads which is rather nice to have).

*** This bug has been marked as a duplicate of 245361 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 1.5 → 1.8 Branch
You need to log in before you can comment on or make changes to this bug.