Last Comment Bug 36168 - Browser: Preferences: Crash when adding screen names to blocked or allowed user lists
: Browser: Preferences: Crash when adding screen names to blocked or allowed us...
Status: VERIFIED INVALID
:
Product: SeaMonkey
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: x86 Windows NT
: P3 critical (vote)
: ---
Assigned To: matt
: scalkins
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-18 00:58 PDT by John Burns
Modified: 2004-11-22 17:25 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description John Burns 2000-04-18 00:58:49 PDT
Bug : Netscape 6 crashes when you try to enter a name into the lists of Allowed 
users or Blocked users in the Privacy section of Preferences.

Steps to Repro:
1. Run Netscape 6 Browser component
2. Click 'Edit'
3. Click 'Preferences'
4. Click 'Privacy', under the 'Instant Messenger' section
5. Under 'Allow List', or under 'Blocked List' click 'Add Name'
6. Enter a 'Screen Name' into the text box that pop's up.
7. Click 'OK'

At this point Netscape crashes.

The Build number that we are working on is : 6.0.15.nb1b.2000040411
Comment 1 John Burns 2000-04-18 00:59:35 PDT
This bug is happening in German and French versions too.
Comment 2 jlarsen 2000-04-18 06:41:00 PDT
This is not the place to report bugs for Netscape beta problems. Please goto
http://home.netscape.com/browsers/6/feedback/problem.html.

Only thing I'm wondering about is, why is a @netscape.com person reporting 
incorrectly, assuming its someone not in the software development departments, 
as I've never see this e-mail before. Marking as invalid?
Comment 3 Blake Ross 2000-04-18 07:46:05 PDT
Never seen this address either...I was also under the impression that 
@netsacpe.com email addresses started with a lowercase letter (just from what 
I've seen throughout reports)...anyways, can anyone verify this on a recent 
nightly?  I'm away from my Moz comp right now...
Comment 4 sairuh (rarely reading bugmail) 2000-04-18 10:45:38 PDT
->scalkins to verif.
Comment 5 scalkins 2000-04-25 10:30:47 PDT
May be dupe of 34674.
Reopening.
This still occurs on Win32 2000-04-21-09 M16 if you have just added a new 
profile and gone into seamonkey with that. If you go directly to prefs then 
without setting up the IM client in seamonkey, you will get a crash.
Stack trace to follow:
Incident ID 9379046 
 Trigger Time 
               2000-04-25 10:28:25 
 Email Address 
               scalkins@netscape.com 
 User Comments 
               TODAY Win32 2000-4-21-09 M16 build Crash after typing name to add 
to allow list in IM privacy settings. 
 Build ID
               2000042109 
 Product ID
               Netscape6 
 Platform ID
               Win32 
 Stack Trace

IMGlue.dll + 0x152bb (0x603c52bb) 
IMGlue.dll + 0xb26d (0x603bb26d) 
XPTC_InvokeByIndex 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, 
line 139] 
nsXPCWrappedNativeClass::CallWrappedMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp, 
line 899] 
WrappedNative_CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp, 
line 195] 
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 687] 
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2484] 
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 703] 
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 776] 
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2796] 
nsJSContext::CallEventHandler 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 768] 
nsJSEventListener::HandleEvent 
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 141] 
nsEventListenerManager::HandleEventSubType 
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
706] 
nsEventListenerManager::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
850] 
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3296] 
nsEventStateManager::CheckForAndDispatchClick 
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
1559] 
nsEventStateManager::PostHandleEvent 
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
730] 
PresShell::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3266] 
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 811] 
nsViewManager2::DispatchEvent 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1355] 
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69] 
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 515] 
nsWindow::DispatchWindowEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 532] 
nsWindow::DispatchMouseEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3238] 
ChildWindow::DispatchMouseEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3443] 
nsWindow::ProcessMessage 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2396] 
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 741] 
USER32.dll + 0x1820 (0x77e71820) 
Comment 6 scalkins 2000-04-25 10:31:48 PDT
cc amusil, lchiang
Comment 7 scalkins 2000-04-25 12:08:23 PDT
Moving Bug to Bugsplat 
http://scopus/bugsplat/show_bug.cgi?id=393233
Comment 8 scalkins 2000-04-25 12:08:42 PDT
verifying moved

Note You need to log in before you can comment on or make changes to this bug.