Status

()

Core
Graphics
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Andrew Schultz, Unassigned)

Tracking

({memory-leak, regression})

Trunk
x86
Linux
memory-leak, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
bug 352174 caused about 1.6K of leaks on nye tbox:
--NEW-LEAKS-----------------------------------leaks------leaks%-----------------------
gfxFontList                                      32          -
nsVoidArray                                      16          -
gfxFont                                        1848     175.00%
nsStringBuffer                                 2056      29.80%
nsTArray_base                                   704       2.33%
Andrew:

Is this a real leaking?
The many objects are owned by global static object in the patch of bug 352174.
Looks like this is same as bug 357779.
Assignee: masayuki → nobody
And I have a question. If this is my leaking bug, why we cannot see the same leaking in Firefox?
http://build-graphs.mozilla.org/graph/query.cgi?testname=refcnt_leaks&units=bytes&tbox=balsa-trunk&autoscale=1&days=7&avg=1&showpoint=2006:11:20:23:09:48,2524
# I checked-in the patch at 2006/11/20 22:30
This is a log of the firefox build that was built after immediately my checking-in.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1164092100.19056.gz
(Reporter)

Comment 4

12 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1164092100.19056.gz

>ac_add_options --enable-default-toolkit=gtk

balsa builds gtk1, which is why it won't show up there.
(Reporter)

Updated

12 years ago
Depends on: 357779
(In reply to comment #4)
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1164092100.19056.gz
> 
> >ac_add_options --enable-default-toolkit=gtk
> 
> balsa builds gtk1, which is why it won't show up there.

Oops, sorry.
# why we are testing the gtk1 on tinderbox??

Comment 6

12 years ago
(In reply to comment #5)
> # why we are testing the gtk1 on tinderbox??

See bug 360206.
i think this is fixed
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.