Changing spellcheck language operates only on one form field

RESOLVED WORKSFORME

Status

()

Core
Spelling checker
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: Floris Lambrechts, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061123 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061123 Minefield/3.0a1

When switching between different spell check dictionaries, only the active form field is spell checked again. As a result, the other form fields are checked using the wrong dictionary.

Adding to this annoyance is the fact that those other form fields cannot easily be switched to the right dictionary because in the UI, the right one is already selected.

Reproducible: Always

Steps to Reproduce:
1. Installed: default dictionary English/US, and add-on dictionary Dutch

2. Fill out a form with multiple fields (say, fields A and B) in Dutch.

3. While in field A, change the spell check language to Dutch.

Actual Results:  
Field A is (correctly) spell checked using the Dutch dictionary, but field B is still checked against the English dictionary.  This may be a feature instead of a bug, but if it is, then the following is a bug:

When now trying to switch field B to Dutch, is is quite hard to do because Dutch is already selected! The only way to force a re-check is to switch to english and then back to Dutch, or to disable spellchecking and then to re-enable it.

Expected Results:  
When changing language, either *all* fields should be re-checked, *or* the change of language should only affect the field in which it was done.

Discovered in Firefox 2.0, verified in daily build 3.0a1 Minefield 2006-11-24.
Can you give an example page?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Can you give an example page?


http://www.spellsaints.org/report.php

e.g. field A is "Text with error: "
and field B is "Corrected text: ".

Regards
Floris
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061123 Minefield/3.0a1

When I go to this page and change the spell-check language to Dutch before typing, every field will be corrected in the Dutch language.
When I have already typed in three fields and then change the language on the first field, the other field are not automatically re-spell-checked. I have to delete the text in the second box first and then re-type it, or first choose English, and then Dutch again.
Assignee: nobody → mscott
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker
Version: unspecified → Trunk
  (In reply to comment #3)
> I have to
> delete the text in the second box first and then re-type it, or first choose
> English, and then Dutch again.
>
Or un-check and re-check "Spell check this field" in the context-menu (works a bit faster). 

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Duplicate of this bug: 443365

Updated

9 years ago
Assignee: mscott → nobody

Updated

9 years ago
Duplicate of this bug: 451030

Updated

9 years ago
Duplicate of this bug: 501022

Updated

9 years ago
OS: Windows XP → All
Duplicate of this bug: 547758

Comment 9

7 years ago
Problem still present in FF4.0b9

STR:

1: Install two or more dictionaries, lets say English (default) & French.
2: Select first language (right click on a text field), lets say English
3: Open a document with two or more text areas. http://www.htmlcodetutorial.com/forms/_TEXTAREA.html
4: Type some words in the other language in BOTH text areas. They should be underlined in red
5: Right click on the first area and select the correct language. The words in this area should not be underlined anymore. However the words in the second area are still underlined i red, even if you can see that the correct language is selected.

Once you change the language for spell checking, all text areas of the page shall be checked again.
(Reporter)

Comment 10

6 years ago
I just noticed that this bug is fixed now (Firefox 9.0.1).

Changing dictionary now applies to all text areas.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.