Inacceptable performance of some SVG examples on Linux

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Andreas Neumann, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

in general, all current Linux builds are extremely slow on my Linux system (SuSE Linux Enterprise) with many SVG examples.

I am reporting this, so that the problem does not get forgotten - we already had a discussion on this issue at the newsgroup, starting at news://news.mozilla.org:119/EeqdnfXQo6GUVNHYnZ2dnUVZ_vednZ2d@mozilla.org

Here is another example with similar problems:
http://www.carto.net/papers/svg/gui/Window/index.svg

It seems like Tim Rowley identified a problem with the cairo library and "cairo_xlib_render_disabled"

So we hope that Cairo will fix this issue in order to get better perfomance in the future.

Reproducible: Always

Actual Results:  
Performance in the given examples is inacceptable. Refresh rates with 1 frame per 2 seconds or so, and the impression that the Xserver hangs.

Expected Results:  
Acceptable performance of the SVG renderer on Linux (similar to the performance on Windows)

Comment 1

10 years ago
Seems to work well today. FIXED ?
Andreas, can you take another look at this using an up to date trunk build? http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 3

10 years ago
performance seems to be ok now on Linux. I tested with another machine, I will test again with the original computer I reported the bug with. It could well be graphics card/Xserver related. I will reporte if its fixed on the other machine as well.

Generally, performance seems to be similar across win/lin/mac now.

Thanks,
Andreas
Okay, so I'll assume this is fixed Andreas. Please reopen if you find the other machine still has problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 5

10 years ago
No specific bug/patch referenced as the fix.  Per comment 3, this may not be related to the browser.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.