"Searchable as comment" flag for attachments would be useful

RESOLVED WONTFIX

Status

()

Bugzilla
Attachments & Requests
--
enhancement
RESOLVED WONTFIX
11 years ago
7 years ago

People

(Reporter: mats, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
"Searchable as comment" flag for attachments would be useful.

I'd like to have an attachment flag that makes the attachment
searchable as if the contents were a comment. And UI to turn that flag on/off.
This is primarily to encourage stack traces being added as attachments
rather than comments (which makes bugs less readable and causes mail
spam).
(Reporter)

Updated

11 years ago
Blocks: 361874

Comment 1

11 years ago
ARG. THIS DOES NOT HELP ME AT ALL. IT JUST ENCOURAGES BAD BEHAVIOR.

Unless you arrange for bugzilla to *send* the attachment to me so that gmail indexes this, i don't want it.

please stop encouraging people to defeat my gmail archive.
No longer blocks: 361874

Comment 2

11 years ago
Dupe of bug 346059 IMO.

Comment 3

11 years ago
note that i didn't intentionally clobber the dependency, bugzilla didn't tell me that was happening.
(Reporter)

Comment 4

11 years ago
(In reply to comment #1)
> Unless you arrange for bugzilla to *send* the attachment to me so that gmail
> indexes this, i don't want it.

Sure, we could have a Bugzilla pref for that I guess.
(Reporter)

Comment 5

11 years ago
(In reply to comment #2)
If bug 346059 intends to make stack trace attachments searchable as if
they were comments that would be good enough for bug 361874.
It's not clear to me if that's the intention though.

This request was for a generic flag that could be turned on/off for
any attachment, although stack traces was what I had in mind of course.
Blocks: 361874
Depends on: 346059

Comment 6

8 years ago
(In reply to comment #5)
> although stack traces was what I had in mind of course.

Bug 346059 would perhaps be a better solution.

Comment 7

7 years ago
All attachments of the form text/plain can be considered as searchable as comment. There is no need for an additional flag. Most users wouldn't understand its purpose.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.