Quoted message has extra line breaks in html format

VERIFIED FIXED in M16

Status

P3
minor
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: craig, Assigned: akkzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
I replied to a message, quoted same, and used text & html for reply format. The 
quoted message was double spaced in the html part of the multipart message.
This was on the 2000041712 build on Win98.

Looking at the raw html, the problem is: the quoted messages is surrounded by 
<pre></pre> tags, AND has <br> at the end of each line. Should lose the <br>s
(Reporter)

Comment 1

19 years ago
Created attachment 7690 [details]
this is the html part of the newgroup message.
(Reporter)

Comment 2

19 years ago
Sorry for the scatter; this is my first bug report. This is the ID of the 
message with the error: 38FBA1EC.6050306@oddworld.com. Its dated April 17, 2000 
in n.p.m.ui on news.mozilla.org. The subject is "Re: Mozilla skin cleanup 
proposal".

Updated

19 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

19 years ago
I think this is my bug -- the formatting code that inserts newlines needs to
detect that it's not inside a pre tag.  It makes life pretty annoying for both
plaintext and html mail (replies come out double-spaced), so I'm also marking
this beta2.
Assignee: ducarroz → akkana
Keywords: nsbeta2
OS: Windows 98 → All
(Assignee)

Comment 4

19 years ago
M16 -- this needs to be fixed asap since it's a dogfood issue.

QA: to test this, send yourself a plaintext message that says:

one
two
three

When the message arrives, reply to it in html compose.  Send it without further
editing.  (Do this once sending as html, again sending as plaintext -- both
modes have problems, but should probably be tested separately since they go
through different code paths.)  When the reply arrives, there should be no extra
blank lines between the "one", "two" and "three" lines.
Status: NEW → ASSIGNED
Target Milestone: --- → M16
(Assignee)

Comment 5

19 years ago
Just checked in a fix for this.  This should fix both plaintext and html.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
Linux (2000-04-21-08 M16)
Win32 (2000-04-21-09 M16)
Mac (2000-04-21-08 M16)
I followed Akkana's instruction, compose a message in Plain text and reply it in
both plain text and Html. No extra blank line is inserted between the line. 

Akkana, I retested it, and only found that one extra line is inserted after the
end of the quated text on all 3 platforms. So that is acceptable.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.