"I'm feeling lucky search" performed on anything that happens to be in the Linux clipboard when pressing the middle mouse button

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: jam_man, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

Upon pressing the middle mouse button in Linux with any version of Firefox (to my knowledge), Firefox performs a Google "I'm feeling lucky" search on any text that Linux user happened to have previously highlight. This cannot be changed to any other search engine, and can only be disabled by use of the middlemouse.contentLoadURL=false option in about:config. This is a confidentiality threat for every Linux user, and is unnecessarily an unchangeable feature that benefits one corporation. However, since this can be considered a convenient feature for some, “middle-mouse” click can be easily made to correspond to an about:config variable that can search using a specified engine (like the browser.search variables in about:config).

Reproducible: Always

Steps to Reproduce:
1.highlight a word (or any text)
2.this text will be copied to the linux clipboard
3.click the middle mouse button within firefox

Actual Results:  
The clipboard text was searched for by use of Google's "I'm feeling lucky" search.

Expected Results:  
In Linux, clicking the middle mouse button pastes text. So Linux users who don't know about this issue have Google search for text that they meant to paste (unless it was an accidental click)
(In reply to comment #0)
> Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8)
> Gecko/20061025 Firefox/1.5.0.8
> 
> Upon pressing the middle mouse button in Linux with any version of Firefox (to
> my knowledge)

You should probably expand your knowledge, at least to 2.0, then: contentLoadURL no longer does anything but load a pasted actual URL. And it could be changed before, since it used the URL from the keyword.URL pref.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> (In reply to comment #0)
> > Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8)
> > Gecko/20061025 Firefox/1.5.0.8
> > 
> > Upon pressing the middle mouse button in Linux with any version of Firefox (to
> > my knowledge)
> 
> You should probably expand your knowledge, at least to 2.0, then:
> contentLoadURL no longer does anything but load a pasted actual URL. And it
> could be changed before, since it used the URL from the keyword.URL pref.
> 

Wow, I wish things like that were in the literature somewhere. Can this be added to a firefox FAQ?
You need to log in before you can comment on or make changes to this bug.