Under certain circumstances, SVG <text> is not displayed in FF@Mac

RESOLVED WORKSFORME

Status

()

Core
SVG
--
major
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: ondra zara, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

10.49 KB, application/zip
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Browser: Firefox 1.5.x or 2.0
OS: Mac OSX 10.4

SVG Text is missing when certain positioning is applied to it's parent.
See http://ondras.praha12.net/svg/test-74px-bad.html and http://ondras.praha12.net/svg/test-73px-good.html - one displays text, one doesn't . The only difference is the 'top' css attribute!!

Reproducible: Always

Steps to Reproduce:
1. open http://ondras.praha12.net/svg/test-74px-bad.html - no text is displayed (MacOS only!)
2. open http://ondras.praha12.net/svg/test-73px-good.html - text is visible
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch

Comment 1

12 years ago
Created attachment 248765 [details]
Simple testcase

This testcase contains a pair of XHTML documents. One renders the SVG text, the other doesn't. The difference is the size of the image contained in an <div> preceding the SVG section.

Comment 2

12 years ago
Simple testcase (attachment 248765 [details]) fails on:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

but not on:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20061204 GranParadiso/3.0a1
For trunk builds this was probably fixed by a cairo update. Since we're not going back to fix this for Firefox 2 users will have to wait until Firefox 3. Since this works on trunk builds, closing as worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.